Email Notifications stopped working

2 days ago outgoing fax email notifications stopped working and yesterday no email notifications are being sent. When I run the debug tool for email under system admin it is showing the from address as [email protected]
I am not sure if this is related but the system flagged this error “You have 1 tampered files (Module: “FreePBX Framework”, File: “/var/www/html/admin/libraries/media/Media/Media.php altered”)”

I upgraded the framework to correct the error but still not emails will go out.

As I am new to FreePBX can someone point me to a log file or a files I can review and see why emails are not being sent?

I should mention we are running Freepbx Version 13

Couple of things to check, the email address is in User Management, have you been on 13 or is this new? are the faxes in the folder /var/spool/asterisk/fax ?

Thank you for the response, emails in User Management is fine. We have been on 13 for sometime now and been using outgoing faxing withing UCP since May of this year with no problem receiving email conformation until 2 days ago. All the faxes are in the folder /var/spool/asterisk/fax/out it seems that Postfix is not sending emails.

I guess I missed this was an outbound fax notification issue, sorry about that… check /var/spool/mail the asterisk user for clues?

The /var/spool/mail asterisk is blank and the last file was asterisk-20160908 this is first part of that log if it helps.

From [email protected] Wed Sep 7 14:24:15 2016
Return-Path: [email protected]
X-Original-To: asterisk
Delivered-To: [email protected]
Received: by localhost.localdomain (Postfix, from userid 499)
id 31B51E2EC3; Wed, 7 Sep 2016 14:24:14 -0400 (EDT)
From: [email protected] (Cron Daemon)
To: [email protected]
Subject: Cron [email protected] [ -x /var/www/html/admin/modules/dashboard/scheduler.php ] && /var/www/html/admin/modules/dashboard/scheduler.php
Content-Type: text/plain; charset=UTF-8
Auto-Submitted: auto-generated
X-Cron-Env: <LANG=en_US.UTF-8>
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <HOME=/home/asterisk/>
X-Cron-Env: <PATH=/usr/bin:/bin>
X-Cron-Env: <LOGNAME=asterisk>
X-Cron-Env: <USER=asterisk>
Message-Id: 2016[email protected]

that didn’t help me, but I seem to remember someone having some issues from the other day, are all your modules up to date? I know faxing had an issue a few days back?

Yes I updated all the modules yesterday in that hopes it would fix the issue.

ok sorry I couldn’t help with it.

Ok thank you for trying.

A few question…

Are you using the Paid Sys admin?

Post the the contents on /var/log/mail_log

Thanks for replying we are using the paid sys admin.

So I believe I tracked it down to my local domain emails. If I change my extension to my gmail.com email I get the VM notifications. When using my local domain email you receive an unknown userdsn=5.1.1, status=bounced (unknown user: “username”)

My mail server logs does not show any error.

Here is an example from the maillog file

Sep 12 11:56:36 sterlingmutuals postfix/pickup[25052]: D8238E05A0: uid=499 from=
Sep 12 11:56:36 sterlingmutuals postfix/cleanup[15720]: D8238E05A0: message-id=[email protected]
Sep 12 11:56:36 sterlingmutuals postfix/qmgr[25053]: D8238E05A0: from=[email protected], size=520, nrcpt=1 (queue active)
Sep 12 11:56:36 sterlingmutuals postfix/local[15722]: D8238E05A0: to=[email protected], relay=local, delay=0.07, delays=0.04/0.01/0/0.02, dsn=5.1.1, status=bounced (unknown user: “plapierre”)
Sep 12 11:56:36 sterlingmutuals postfix/cleanup[15720]: E40D7E0601: message-id=[email protected]
Sep 12 11:56:36 sterlingmutuals postfix/bounce[15723]: D8238E05A0: sender non-delivery notification: E40D7E0601
Sep 12 11:56:36 sterlingmutuals postfix/qmgr[25053]: E40D7E0601: from=<>, size=2327, nrcpt=1 (queue active)
Sep 12 11:56:36 sterlingmutuals postfix/qmgr[25053]: D8238E05A0: removed
Sep 12 11:56:36 sterlingmutuals postfix/local[15722]: E40D7E0601: to=[email protected], relay=local, delay=0.02, delays=0/0/0/0.02, dsn=2.0.0, status=sent (delivered to mailbox)
Sep 12 11:56:36 sterlingmutuals postfix/qmgr[25053]: E40D7E0601: removed

Ok fixed the unknown user issue by entering proper hostname. But Faxes and VM notifications are still not working. Sending an email from User manager and Debug for emails both work. The issue with VM is it still wants to use [email protected] instead of what I setup. I have set every everywhere that I found in the system to use [email protected],

My mail sever requires authentication so [email protected] is getting permission denied. Where do I set what email VoiceMail notifications are sent from.

thanks for any help, for the record all for this was working for month until last week. Something had to have change with one of the resent updates.

Under advanced setting and search for from address

Yes I have the email in advanced setting set to the email I want to use. With testing here is what I found.
Email Debug tool uses [email protected] recipient receives email from [email protected]
User Manager uses what I have in the system [email protected] recipient receives email from [email protected]
Voicemail uses [email protected] recipient receives email from [email protected]

I also notice that not all the changes I set in the Email Settings under System Admin are saved to the /etc/postfix/main.cf file. Everything I type in the fields are fine but for example NO TLS, or No Authentication settings do not update in the main.cf file, I have to change them manually.

Not sure if this is a bug but will enter a ticket. This was working for me in the past.

The only notices I am not receiving which started all the problems is from FaxPro. I do not receive any log enters in /var/log/maillog do you know if FaxPro uses a different log file? It’s hard to troubleshoot without the error logs.

Thanks again for the help.

^^ I think you missed this error. You’re trying to send to an account that doesn’t exist.

No the account exists, it was the Host name setting in the “Email Settings” I had it set to my Domain name. Once changed that error was cleared and email was working again. Except for outgoing Fax Confirm email, I am still not receiving and there is no error in the maillog to see why. Any Ideas on where to review why they are not being sent?

Hi!

I believe that essentially resulted in Postfix on the PBX thinking that it was the final destination for that domain name (what Postfix calls “mydestination”) and expecting the “plapierre” account to exist on the PBX…

The hostname is one of the default entries of “mydestination”…

See http://www.postfix.org/postconf.5.html#mydestination

Have a nice day!

Nick

Nick, Thanks for the post that helps explains why it was reporting unknown user.

Cheers
Paul

We actually started having the same issue a couple of days ago.

We can receive incoming faxes through email fine, but we no longer receive the confirmations for outgoing faxes. Its still enabled in the global settings and the per user settings.

I checked /var/log/maillog and I do not see any information about the confirmation. No attempt, no failure, nothing. I see emails for other system notifications and for the incoming faxes and voicemails etc

Possibly a bug introduced in a recent module update??