Email Has Wrong Sent From Address

Hello! I am moving my company email off @gmail.com and onto another email provider with my own domain name, say @newemail.com.
I updated the email settings in Sysadmin and updated /etc/postmay/generic, then did postmap. The generic.db file has the correct email addresses listed. I mainly use this to send faxes. I am receiving faxes, but they are being listed as spam because they still contain the @gmail.com address in the sent from line. The debug happily reports the email being sent as from [email protected]. Here is the debug log:

BlockquoteJun 1 23:12:37 freepbx postfix/pickup[17679]: D409F20542E2B: uid=995 from=
Jun 1 23:12:37 freepbx postfix/cleanup[19540]: D409F20542E2B: message-id=[email protected]
Jun 1 23:14:46 freepbx postfix/qmgr[17680]: 2E005205D8317: from=<[email protected]>, size=53791, nrcpt=1 (queue active)
Jun 1 23:14:46 freepbx postfix/smtp[19909]: 2E005205D8317: to=[email protected], relay=mail.newemailserver.com[correct IP address]:25, delay=42237, delays=42237/0.01/0.05/0.09, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 20EFB2980FD1)
Jun 1 23:14:46 freepbx postfix/qmgr[17680]: 2E005205D8317: removed
Jun 1 23:54:46 freepbx postfix/qmgr[17680]: 222A920542E1D: from=<[email protected]>, size=55722, nrcpt=1 (queue active)
Jun 1 23:54:46 freepbx postfix/smtp[27978]: 222A920542E1D: to=[email protected], relay=mail.newemailserver.com[correct IP address]:25, delay=9142, delays=9142/0.01/0.06/0.1, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 34CB62980FD1)
Jun 1 23:54:46 freepbx postfix/qmgr[17680]: 222A920542E1D: removed

What setting am I missing?
Thank you for looking this over.

Not sure if this is will help, but under Settings, Voicemail Admin, Settings, Email config, you need to update the email address if you get voicemail as email.

@ozarktech
Thank you. That did the trick.

drnate

@ozarktech
Your suggestion for the voicemail and fax worked well. Thank you. The service that emails me backup confirmation is coming through as spam now. Do you know where to change that setting?

If it’s using the built in mail server, it will be flagged as spam, but if you are using your own mail server it may or may not be. I know there’s some settings to check but don’t remember what they are offhand.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.