Eliminate CallerID Name from inbound calls

Hello Everyone,
currently still testing freepbx 15 and I am trying NOT to receive the CallerID name.
Happy to see the caller number but I user the CID name prefix and I don’t need the caller name to be added to it.
Hope it makes sense.
Any advice?

Depend if your CID name come from contact manager, or Asterisk phonebook, or from trunk.
If you want to remove any CID name, you must create a custom context removing the CID name part.

Then maybe you should do like this.
Edit /etc/asterisk/extensions_custom.conf, and add

exten => _X.,1,Set(CALLERID(name)="")
exten => _X.,n,Goto(from-trunk,${EXTEN},1)

Next, change from-trunk to from-trunk-no-cidname in your trunk settings

Just an idea like that. :wink:

Thank you danarf,
I have added in extensions_custom.conf
can’t see where to change from-trunk to from-trunk-no-cidname no in trunk settings.
I’m testing on Call Centric if it helps

Go to Connectivity / Trunk
Select your trunk
Select tab : Sip Settings or PJSIP settings.
Change your context
Save and apply.

I don’t know Call Centric, sorry.

1 Like

More important than hiding the CID Name, why don’t you disable the CID lookup from the provider.

They charge you for it anyway. All carriers do. It is not something they get for free.

1 Like

Caller ID Superfecta has a CID module called ‘Abandon Lookup’ which allows you to substitute your own text (or the CID Number) in place of the CID name.


Did disable there but still showing. Thank you for youtr input anyway.

Still showing… wondering though… is this only for abandons?

No luck on anything.
I have added a CID on the inbound route: 1234 and on the caller name I would like to only see 1234 …
tried all the suggestions and still getting 1234Bob (where Bob is the caller Name).

Any help appreciated

If you select Superfecta, you need to setting up Enable Superfecta Lookup in the inbound route, tab Other and set Enable Superfecta Lookup to Yes, and select something in Superfecta Scheme

Set CID Lookup Source to No

Save and Apply.

1 Like

Thank you, it works but when leaving the box empty it replaces with ‘Unknown’…

It’s normal, If there’s no CID(name) then it displays Unknown. Normal behavior
Maybe insert a space " " in CID(name) instead of empty “”.

Otherwise, you can try to play with Advanced SIP settings. Chan_sip and in Other SIP Settings rewrite callerid, set a space to change Unknow by default.
I don’t know if that will work.

Just an idea like that

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.