Sangoma Completes Acquisition of Digium: Sangoma Press Release. Community FAQ: Sangoma and Digium Join Together FAQ
FreePBX | Register | Issues | Wiki | Portal | Support

Elastix and Panasonic TDE


(Fgonzales) #1

Does anyone know how I can connect two PBX in different locations, connected through an IPSec (NO NAT). I want only for communications between extensions with different outside providers?

The SIP Trunk on Elastix is:
Trunk Name: Panasonic
PEER Details
host=192.168.10.100
username=1234
secret=1234
type=peer
context=from-trunk
qualify=yes

USER Context: 1234
username=1234
secret=1234
type=friend
context=from-internal

In Panasonic TDE - The Port Property - Virtual SIP Gateway the configuration is:

Main Tab
Channel Attribute = Basic channel
Provider Name = Panasonic
Name = 1234
IP Address 192.168.13.100

Account Tab
User Name = 1234
Authentication ID = 1234
Authentication Password = 1234

Register Tab
Register Ability = Disable
Register Sending Intervals = 3600
Un-Register Abilitiy when port INS = Enable
Registrar Server Name = 1234
IP Address = 192.168.13.100

The connection in the PANASONIC is IN but in the Elastix is UNREACHABLE.

Thanks.


#2

Can you ping each pbx from the other side?

Panasonic IP PBXs often need a license in order to use SIP trunking. Do you have the required licenses installed?


(Fgonzales) #3

Yes, I can make ping and the Panasonic has a license.


#4

With no logs, I can only guess:

Possibly, the Panasonic binds to a port other than 5060 and you would need to specify that on the Elastix side. At the Asterisk console, do
sip set debug on
and make a call from the Panasonic side. See what port it came from; if different from 5060, put a port=xxxx parameter in your peer details, after host=192.168.10.100.

Or maybe, the Panasonic doesn’t support OPTIONS properly. Try removing the
qualify=yes
and making a call from the Elastix side. If it doesn’t work, there may be a response from the Panasonic that gives a clue as to what’s wrong. Again, SIP debug is your friend.


#5

Have you debugged the trunk on elastix?

If I were you, I would completely delete the USER section and set the peer details with type=friend and context=from-internal

Also check username and from parameters, you might need them. But first try to debug the trunk so you can see the exact error that might be happening.


(Lorne Gaetz) #6

Not related in any way to your question, but when the time comes that you want to migrate from Elastix to a supportable system, you want this page:
https://wiki.freepbx.org/display/PPS/Elastix+and+PBXinaFlash+to+FreePBX+Distro+Conversion+Tool


#7

See if this post helps. OP is explaining how he managed to create a trunk between freepbx and tde600


(Fgonzales) #8

I can’t post the code., detects that the code has links.

Image attached.
Thanks.


(Fgonzales) #9

Is working now.

The configuration is:

The SIP Trunk on Elastix is:
Trunk Name: Panasonic
PEER Details
host=192.168.10.100
username=1234
secret=1234
type=peer
context=from-trunk
qualify=yes

USER Context: 1234
username=1234
secret=1234
type=friend
context=from-internal

register string:
1234:1234@192.168.10.100:5060

Also in the Outbound Routes
I have to mark the option Route Type = Intra-Company

In Panasonic TDE - The Port Property - Virtual SIP Gateway the configuration is:

Main Tab
Channel Attribute = Basic channel
Provider Name = Panasonic
IP Address = 192.168.13.100
SIP Server Port Number= 5060

Account Tab
User Name = 1234
Authentication ID = 1234
Authentication Password = 1234

Register Tab
Register Ability = Disable
Register Sending Intervals = 3600

and now, when I call from Panasonic to Elastix it’s display the caller name and extension. But, when is from Elastix to Panasonic only display the extension number.
Is there any option to also send the name?

Thanks.


#10

Not sure, Panasonic for public trunk devices only support caller-id number, only for Q-sig modes could displayed name, but it depends to each device interoperability.