Editing extensions.conf through freepbx

Add this to extensions.conf for asterisk pbx server setup
[outbound]
exten => _1NXXNXXXXXX,1,Dial(SIP/${EXTEN}@vitel-outbound)
exten => _011.,1,Dial(SIP/${EXTEN}@vitel-outbound)

; e911 must be enabled. see DIDs > NPANXXNXXX > Action > e911
exten => _911,1,Dial(SIP/[email protected])

[inbound]
exten => 3195533625,1,Answer

Where can I enter this information in freepbx? I signed up for a DID with vitelity, and have not been able to call out to other phones.

You may want to start by RTFM.
A DID does not “call out” nor give you ability to make any calls.

tompoe,

sounds like you may be reading generic Asterisk instructions. You never want to use such instructions on a FreePBX system, they are almost always guaranteed to break you. Look for their FreePBX instructions.

And, to put the ‘advertising hat on’ if you want to help support the FreePBX project, feel free to go to https://store.freepbx.com. If you sign up there and ping us at the support email, I’ll send you a beta module that will automatically configure your system for you :slight_smile:

advertising hat off

Thanks, much Geek Boy, tadpole. Keep up the good work.

Why are you editing the file directly instead of adding a TRUNK through free pbx? Vitelity has a step by step guide on how to add a DID through them.

Hi, Kieranmullen3: Just trying to figure out where the vitelity info provided needs to be entered.
7/22 add to end of sip.conf for asterisk pbx server setup
[vitel-inbound]
type=friend
dtmfmode=auto
host=inbound16.vitelity.net
context=inbound
allow=all
insecure=very

[vitel-outbound]
type=friend
dtmfmode=auto
host=outbound.vitelity.net
context=outbound
insecure=very
allow=all


I entered the above in trunk peer and inbound.

Add this to extensions.conf for asterisk pbx server setup
[outbound]
exten => _1NXXNXXXXXX,1,Dial(SIP/${EXTEN}@vitel-outbound)
exten => _011.,1,Dial(SIP/${EXTEN}@vitel-outbound)

; e911 must be enabled. see DIDs > NPANXXNXXX > Action > e911
exten => _911,1,Dial(SIP/[email protected])

[inbound]
exten => 3195533625,1,Answer


  • I don’t know where to enter this stuff. Any help appreciated.

Yes, those are both trunks. In each setting, you have incoming and outgoing settings.
You will have to make two of them.

Look at the TOOL TIPS on the side of each field with an underline. On each page at the top you will see a HELP link. Each page you take you to the corresponding help page on this site.

Read it all.

tompoe,

those are ‘bogus’ instructions as indicated above, they are directed at raw Asterisk, not FreePBX. You don’t want to follow them (though the trunk information should map into the proper trunk fields for FreePBX).

You want to find the instructions FOR FreePBX, hopefully the vendor provides them. Example instructions for the SIPSTATION configuration is:

http://freepbx.org/freepbx-trunks

note it says it is for FreePBX. That is what you want to find for your other provider if that is what you want to use.

GeekBoy: Thanks for that info. I had not paid attention, beyond the tool tips. Will do.

Vitelity.com instructions … login to portal>click support…click on · Trixbox Inbound Trunk (They use(d) freepbx for the GUI) There are pictures there & everything…

thanks, Kieran. I now can dial on xlite, and it reports connected, then trying, then 404 fail. Logs tell me the inbound16.vitelity.net not found. Will focus on logs now, and learn about troubleshooting configuration. I’ve got ping to nameserver, inbound16.vitelity.net, through tracepath. Thanks, much.

idk about xlite. These are my working settings however bad they may seem to the experts. They work Did you put the register string in?

PEER Details

username=USERNAME
type=friend
secret=PASSWORD
insecure=very
host=SERVER
disallow=all
context=from-trunk
canreinvite=no
allow=ulaw

USER Context and Details

Blank

String

USERNAME:[email protected]:5060

I found the trixbox samples, and they match up pretty close to what you have. Your user info is placed in the peer detail section. Tomorrow, I’ll try your format. Wish me luck. Thanks, again.