Dynamic ip with noip.com


I’ve installed a new FreePBX with a dynamic IP.
At PAP2 I’ve entered Proxy: *****.ddns.net:6030
and get Registration State: Can’t connect to login server
If I’m entering the IP directly the PAP2 connects perfectly to the FreePBX
I mention that if I’m performing a ping to ****.ddns.net I’m getting the same IP as the number I’ve entered directly.

Does anyone has any idea ?

Thank you :smile:

I used to use a PAP2 myself, but I can’t remember the settings. I would look for the following. DNS servers, you will need to manually set these probably unless you specify these settings within a DHCP lease. Gateway, make sure it is set also, if it is remote to your server, of which I presume it is, you will need to use the gateway of the local router.

As the PAP2 can’t establish the IP address from the given domain name, this has to be a DNS issue. That is what you should be looking for.

I seem to remember the PAP2s had an extremely long delay on ring time too, I did get rid of my PAP2s and moved over to Cisco ATA 188s which are a much nicer unit for around the same price (eBay).

Just putting that out there.

Thank you deanot26508

Your tip was perfect. I still don’t understand but I’ve solved the problem.
The Asterisk’s IP was static and the IP of PAP2 was obtained through DHCP.
When I defined a static IP (Including DNS !) at the PAP2 everything worked fine.

Happy New Year 2015 to ALL !!!

You are welcome, the issue was most likely because the PAP2 had no idea where to look for the IP to domain resolution, so it just sits there and will time out. Glad it is working for you, and I am sure you will notice the lag or time it takes to ring, I think mine had a delay of 5 seconds before it would ring, and that was on a local network…

Enjoy and have a wonderful new year.