Dynamic IP behind NAT not working for me, so audio issues

Hi there, I’ve been reading several posts about the problem I have and I finally found the problem. I’m behind a NAT and I had 2 way audio issues after following all the official tutorials -having and configuring a dynamic IP-. I tried setting my IP up as a ‘Static IP’ and it worked like a charm, so my problem is with DNS resolving.

I tried 3 different DNS providers with no luck, 2 way audio issues all the time. I even tried changing the refresh rate from 120 to 60s, just in case.

So, I’m stuck!! Any ideas? You are all welcome to say your piece.

PS: I also tried setting up my ddns client on the router, not by software.

I would check your Asterisk General Sip Settings and Chan Sip settings under FreePBX. Is your dynamic IP correct?

Yes, my dynamic IP has been triple checked -all three different accounts-.

What exactly would you check in Asterisk General Sip Settings and Chan Sip settings?

Check your NAT and IP Configuration . I have a dynamic IP and so far have not had any issues. Maybe override External IP under Chan SIP settings with your FQDN?

I have the following settings that are working fine.

General SIP Settings

External Address - Set to my FQDN

STUN Server Address - stun.sipgate.net

Chan SIP Settings

NAT - Yes

IP Configuration - Dynamic IP

Dynamic Host - Set to my FQDN

Dynamic Host Refresh - 120


I also have the following entry in /etc/asterisk/dnsmgr.conf

enable=yes ; enable creation of managed DNS lookups
; default is 'no’
refreshinterval=300 ; refresh managed DNS lookups every seconds
; default is 300 (5 minutes)


Settings in System Admin are:
(local router IP)

With chan_this has been working without problems…

You guys rock. I overrided External Address under General SIP Settings and added the STUN Server and now it seems fine.

Thank you.

1 Like