DualSim Nokia 2.1 Chan_mobile call routing problem

Hello!
I have a Nokia 2.1 DualSim phone, connected to RasPBX (Asterisk 13.27.0) via BT. The connection still works (was not sure about rfcomm port number so i leaved default 3), but the calls will not forwarded to my extension (1000, sip extension).
Mobile conf looks like:
[general]
interval=30

[adapter]
id=blue
address=00:02:72:D2:XX:XX

[Nokla21]
address=AC:57:75:2E:XX:XX
port=3
context=from-internal
adapter=blue
group=1

raspbx*CLI> mobile show devices
ID Address Group Adapter Connected State SMS
Nokla21 AC:57:75:2E:XX:XX 1 blue Yes Free No

By the inbound routes i use ANY for CID and DID.

Extension 1000 have also the from-internal context, but call don’t forward to extension. The log looks like:

pbx.c: Executing [[email protected]:1] Goto(“Mobile/Nokla21-e58d”, “11,1”) in new stack
pbx_builtins.c: Goto (from-internal,11,1)
pbx.c: Executing [[email protected]:1] ResetCDR(“Mobile/Nokla21-e58d”, “”) in new stack
pbx.c: Executing [[email protected]:2] NoCDR(“Mobile/Nokla21-e58d”, “”) in new stack
pbx.c: Executing [[email protected]:3] Progress(“Mobile/Nokla21-e58d”, “”) in new stack
pbx.c: Executing [[email protected]:4] Wait(“Mobile/Nokla21-e58d”, “1”) in new stack
pbx.c: Executing [[email protected]:5] Playback(“Mobile/Nokla21-e58d”, “silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer”) in new stack
file.c: <Mobile/Nokla21-e58d> Playing ‘silence/1.slin’ (language ‘en’)
file.c: <Mobile/Nokla21-e58d> Playing ‘cannot-complete-as-dialed.slin’ (language ‘en’)
file.c: <Mobile/Nokla21-e58d> Playing ‘check-number-dial-again.slin’ (language ‘en’)
pbx.c: Executing [[email protected]:6] Wait(“Mobile/Nokla21-e58d”, “1”) in new stack
pbx.c: Executing [[email protected]:7] Congestion(“Mobile/Nokla21-e58d”, “20”) in new stack
pbx.c: Spawn extension (from-internal, 11, 7) exited non-zero on ‘Mobile/Nokla21-e58d’
pbx.c: Executing [[email protected]:1] Macro(“Mobile/Nokla21-e58d”, “hangupcall”) in new stack
pbx.c: Executing [[email protected]:1] GotoIf(“Mobile/Nokla21-e58d”, “1?theend”) in new stack
pbx_builtins.c: Goto (macro-hangupcall,s,3)
pbx.c: Executing [[email protected]:3] ExecIf(“Mobile/Nokla21-e58d”, “0?Set(CDR(recordingfile)=)”) in new stack
pbx.c: Executing [[email protected]:4] NoOp(“Mobile/Nokla21-e58d”, " montior file= ") in new stack
pbx.c: Executing [[email protected]:5] GotoIf(“Mobile/Nokla21-e58d”, “1?skipagi”) in new stack
pbx_builtins.c: Goto (macro-hangupcall,s,7)
pbx.c: Executing [[email protected]:7] Hangup(“Mobile/Nokla21-e58d”, “”) in new stack
app_macro.c: Spawn extension (macro-hangupcall, s, 7) exited non-zero on ‘Mobile/Nokla21-e58d’ in macro ‘hangupcall’
pbx.c: Spawn extension (from-internal, h, 1) exited non-zero on ‘Mobile/Nokla21-e58d’

What make i wrong?

Setting
context=from-trunk
will probably get incoming calls to ring your extension, but if there is no audio, see

@ [Stewart1]
Thank You, as You wrote, the problem was the sound, because i have muted my phone.
The problem is solved.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.