FreePBX | Register | Issues | Wiki | Portal | Support

DTMF tones not working with DISA


(Jasonc) #1

I set up a freepbx 15.0.11 and am trying to use the DISA function. I have it set up per the docs and get my secondary dial tone. It does not recognize any dtmf tones when trying to dial the outgoing number. I have tried all the options for inband, rfc, etc. Any ideas?


#2

Confirm that when you press a key the dial tone keeps playing.

Does your DISA have a password? If so, confirm that your password is properly recognized and you hear ‘Thank you’ then dial tone. In that case, I suspect that some echo or other interference from the dial tone is preventing additional DTMF from being recognized.

If not, set a password for testing. Does the password get recognized, or do you hear “password incorrect” after about 10 seconds? If the latter, DTMF is not recognized at all.

In Advanced Settings, what is the setting for Country Indication Tones? What country are you in? What kind of incoming trunk (POTS, PRI, GSM gateway, SIP, etc.)? If not SIP, what hardware connects it to FreePBX? What kind of device are you calling from (corded phone, cordless phone, mobile phone, etc.)? How is it connected to the network (copper pair, cable MTA, fiber ONT, etc.)?

With these answers, we should have some ideas on where to look for the trouble.


(Jasonc) #3

I will try to answer all the questions.

  1. When I press a key the dial tone keeps playing
  2. I have tried the DISA with and without a password. It times out with the password and doesnt get the tones without it.
  3. Advanced settings country is the US/North America and I am in the US.
  4. I am using a SIP trunk
  5. I have tried calling from landlines and cell
  6. FreePBX is a VM running in our data center

Thanks for your reply.


#4

OK, so it appears that DTMF either doesn’t function on the incoming trunk (most likely, trunk not configured correctly) or it doesn’t work at all (build or compilation error, etc.)

Add a Misc Application. For example, Description: disatest; Feature Code: 2222; Destination: DISA (your DISA).

Now, from an internal extension, dial 2222. You should be connected to the DISA, just as if you dialed in from outside. Report whether your DTMF is recognized and we’ll take it from there.


(Jasonc) #5

I work for the provider as well so I built the SIP trunk on the carrier side. It is correct. Unless you mean the trunk build in the PBX?

I will test a physical phone.

Thanks again


(Lorne Gaetz) #6

I suspect that this is a NAT issue, no inbound RTP (including DTMF) until after outbound media is sent. Try routing an inbound call through an announcement before the DISA and see if it fixes.


#7

This sounds like you have a specialty application, where the PBX normally would not have any extensions.

In that case, test by setting your Inbound Route to Feature Code Admin -> Echo Test. If you hear the introduction but your voice is not echoed, there is an issue with inbound media from the trunk. In that case, first check Asterisk SIP Settings -> External Address and Local Networks. If you modify these, you must restart (not just reload) Asterisk. If that’s not your trouble, check your firewall settings.


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.