DTMF problems with callback

I installed the Ruby script in order to get the callback module working. All is well and I can dial into a specific Sipgate DDI from my mobile and a few seconds later get a callback via a Voipcheap trunk. Trouble is when the lovely lady asks for my PIN the dtmf tomes are not recognised. If I try calling in from another Sipgate phone the tones are recognised.

I know Sipgate uses dtmf INFO while Voipcheap is inband. How do I set up the dtmf to work using the Voipcheap trunk?

How about in the outbound details
dtmf=inband
dtmfmode=inband

Note that with inband you have to use g711 ulaw.

on Thursday 11/09/2006 trottm([email protected]) wrote

I installed the Ruby script in order to get the callback module working. All is well and I can dial into a specific Sipgate DDI from my mobile and a few seconds later get a callback via a Voipcheap trunk. Trouble is when the lovely lady asks for my PIN the dtmf tomes are not recognised. If I try calling in from another Sipgate phone the tones are recognised.

I know Sipgate uses dtmf INFO while Voipcheap is inband. How do I set up the dtmf to work using the Voipcheap trunk?


Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users


Your life is like a penny. You’re going to lose it. The question is:
How do
you spend it?

     John Covici
     [email protected]

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

Post generated using Mail2Forum (http://www.mail2forum.com)

You get the gold star for that fix! I owe you a beer. I already had tried dtmfmode=inband, it was the dtmf=inband that fixed it. What is the statement actually doing that dtmfmode isn’t?

Also depending upon which phone I dial into Trixbox from I don’t get a ringing tone. I remember having and fixing this problem a long time ago on [email protected] but can’t remember for the life of me what I did? Another beer is waiting for this fix.