DTMF not recognized on DAHDI fxs ports


(United States) #1

I have a simple setup, an AEX800p card configured with 8 fxs ports. When you plug an analog phone into any of the ports and try to dial, no dtmf is heard. The line responds accordingly (dial tone just eventually times out).

I’ve tried setting dtmfmode=inband and relaxdtmf=yes in the global channel configuration to no effect. I’ve tried two different analog phones, one of which works fine on a different (grandstream) ATA. I’m sure this is something easy but I’m stumped.

Thanks in advance.


#2

Not that it might be directly related but have you connected the power cable to the card?


#3

Sorry, I know nothing about this card, but it’s possible that the issue is unrelated.

Confirm that DTMF works properly from other extensions (IP phone, softphone, SIP app, etc.)

When you call an analog phone on the card, does the phone ring and provide two-way audio? If so and you press keys on the phone, does the caller hear the tones? Does DTMF logging in Asterisk show the keypresses?


#4

Dahdi DTMF can only be done ‘inband’ so the presence of ‘battery’ (the 4 pole molex connector being connected with +12v (yellow) and 5V (red) on it) is possibly relevant . . .

Add DTMF to console and full logging.


(system) closed #5

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.