DTMF issues with Sangoma A400 FXS/FXO


(Rob S) #1

I can’t seem to get DTMF to work on calls the way I need to.

I have an A400 card in a PBXAct box with 8 FXS and 4 FXO. When on a call FreePBX not passing the DTMF on the FXS lines. I get a slight chirp sometimes but most of the time it’s just a “thunk” or click.

Our IP phones are Sangoma S705’s and S505’s. They show the same issue as on the FXO lines (old conference phones no one wants to give up) which can make dialing up a conference a royal pain when you can’t enter the conference ID#. Like I said I get a slight chirp sometimes but most of the time it’s just a “thunk” or click.

What setting(s) do I need to concern myself with to get DTMF to work while on call instead of, I’m guessing, being interpreted?

Right now I have “SIP DTMF Signaling” set to “auto” on the FreePBX Advanced Settings page.


#2

You might try turning off or changing the echo cancellation settings, at least temporarily. Check files in /etc/wanpipe/ directory. Also plug those call flows into test IVRs directly, just to see if it is enough ‘chirp’ to trigger the correct menu options.


(Rob S) #3

Made the changes in wanpipe and had to reboot to get it to take… It worked! For all of 3 minutes. Then it went right back to blocking them.

If I restart FreePBX/Asterisk I get about a minute or two of it working then it stops, reboot the machine and I get about 3 minutes.

This is so extremely frustrating. I just want the system to be “dumb” about DTMF during a call, at this point I don’t care if I lose in-call feature codes.


(Rob S) #4

I was able to get some reboots done and I’m now 75% sure that it’s only after the first call after reboot that DTMF works as expected, not based on time running like I originally thought. So one call works, then it goes into DTMF blocking.


#5

Sounds like some progress ?

Also does it affect all the phones ? Even maybe a soft phone from your PC ?

Other files to check include:

…there are various echo cancelers and settings there that you can try out while tuning your lines.


(Rob S) #6

I’ve determined that it is something between dahdi and asterisk that there is no access to. It happens on all calls, all phones (VVX 400, S505, S705, Zoiper), all lines, except the first outbound call after a restart of asterisk.

Disabling or reducing echo cancellation on the dahdi side has little affect, except to add echo problems and feature problems on top of the DTMF ones.

I’m going to be trying adding a SIP outbound line to see if this is present there. If that works, I’ll add a dial prefix to get to that line if people need DTMF on a call.

I’ve basically given up and as soon as it’s feasible, I’ll be ditching FreePBX for something much better. I’m so spent dealing with issues between this and the crappy support on the Sangoma phones that I don’t care what that will cost in professional or monetary concerns.


(system) closed #7

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.