DTMF Issues Randomly Not Picking Up Entries

I had a FreePBX system installed maybe six months ago. I have had random issues with DTMF being read properly, but it is only certain people that call in. Some it will be an office desk phone that they cannot dial any extensions so they are put to the default customer service queue, but they can pick up the phone in a different office and it works just fine. I also have an employee that has an iPhone that cannot dial the proper extension and has even since received a brand new phone and still has the issue.

I enabled the DTMF log under the Asterisk logs and can see where they dial ‘3315’ and the system only picks up ‘1’. Is there anywhere to tweak the sensitivity or has anyone experienced something similar?

This is certainly annoying behavior many of us have dealt with. How do the trunks from the outside come into your office? Are they VoIP, PRI, POTS?

They are PRI over fiber

What type of device is handling your PRI-SIP conversion?
Can you share the PBX side configurations for that SIP /DAHDI settings for that device?

I am not sure where to find this information to share it.

Is there any information under “TRUNKS” in the FreePBX GUI by chance? CONNECTIVITY->TRUNKS

I have an employee that has always had this issue. I just did some testing with them and they had the issue on a landline as well as on a cell phone. We tried 8 times and it worked fine, then twice it didn’t work. I am using dahdi_monitor to save the tones that are received and then uploading these to an online dtmf detector that is reading the proper tones, but the system is not.

For example, he was trying to dial extension 3305 and it appears the system never read the two 3’s, and started with the 0 which sends him to the customer service department.