Driving me Crazy! Sip From contains private IP

Hey guys running latest stable build, SNG7-PBX-64bit-1805-1 with Asterisk 13.

Simple pjsip trunk to TSP and my pcaps are showing the From field has the private IP address. At that point the TSP gives me a 403 forbidden.

A working call via another server has the correct FROM with the public ip and all works fine.

Where the heck to make the changes to get this to show the correct IP.

Nothing to do with my Firewall these are captures before they hit the firewall.

I think I’ve got all my NAT Settings in General SIP Settings tab correct. It picks up the correct External Address when I press the Detect Netowork Settings. The local networks are correct, just,

The from field looks like this on the non working side.
From: sip:[email protected]; tag asdfasdf blah blah blah

The via field, contact and SDP address show the correct public IP, what am I doing wrong!

Thanks I know it’s got to be something super easy I’m just missing. Let me know if you need any further details! Screenshot ect


There are (at least) two places that need to have NAT set correctly, and your symptom indicates that this is not set up right yet.

The first is on the “General SIP settings” in the Advanced tab.
The second is on the trunk settings when you set up the trunk.
The third is on your extension settings - make sure all of them are set up correctly and you should be in better shape.

if you are using pjsip, go to the sip settings/pjsip section and the first option is allow reload. Change it to yes. The submit and apply. Try again. That fixed it for me.

This fixed it for me, hope it help someone else.

In the Trunk settings -> pjsip Settings -> Advanced Tab

Contact User: asterisk
From Domain: public Nat’ed IP address.

Now the debugs Invite looks perfect and outbound calls are flowing. That was my first pjsip trunk and it took a little experimentation to get it right!

Hope it help someone!

Thanks everyone for their responses

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.