Does a Sangoma P370 phone not support TLS?

All our Digium and Sangoma phones connect to our freepbx server via tls.

Now in our first P370, in the “Choose Sangoma Configuration Server” dialog, only udp and tcp are available. Hence the phone does not fetch a configuration.

“About” says “Version 4_1_1-20220218170819” <= Is that ancient firmware? Yet without a server connection and the web ui locked, it can not be updated.

What might be wrong?

Managed to upgrade firmware to 4_13_5, yet still no tls. What is the drill?

That’s just a boot config UI issue - known issue, will get handled in a future release. Phone already supports TLS.

Phones use the transport as defined by the config_server_url parameter and the transport option of the host_primary in their config. Phones default to UDP. If you select that or TCP, the phone will make contact using UDP or TCP. The phone’s config isn’t sent in the clear in any of the transports (UDP, TCP, or TLS). Once the phone gets a config that tells it to use TLS, it’ll restart and use TLS. So, you’ve gotta bootstrap it using UDP or TCP first…or you’ve gotta have a multicast or Option 66 string that specifies the transport or you’ve gotta use ZTP or you can browse to http://phoneip/configserver if you don’t want to bootstrap.

1 Like

Actually…I like it the way it is…since I do not want to fool around with certificates, when all phones are in a local network :wink:

Thanks very much Malcolm, excellent advise as always! :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.