Do Not Disturb Question


Whenever I enable DND using *78, is it not supposed to play a special tone when off hook to remind you that you have it activated? Kind of like voicemail stutter tone. If so, how do you enable the special tone?

Secondly, how do I set the system up that when DND is enabled calls from certain numbers are allowed through…For example, my cell phone or my work?

Any help would be appreciated!

If you enable DND with *78 and you dial that extension form either a local extension or an outside call you will get a Congestion.

There is no way in Trixbox or FreePBX to actually detect if DND is activated.

If DND is set, dialparties.agi will return NOANSWER and there is no code to detect that and it falls through to this line in extensions.conf:

; Anything but BUSY comes here
exten => _s-.,1,Congestion()

To solve that add the following lines to extensions.conf:

; Extensions with DND ends here
exten => s-NOANSWER,1,NoOp(Extension is reporting Busy, DND on)
exten => s-NOANSWER,n,Busy() ; play busy tone
exten => s-NOANSWER,n,Wait(60) ; wait 60 seconds
exten => s-NOANSWER,n,Hangup() ; hangup the phone

The code should be inserted in the macro-exten-vm context after this code

; Extensions with no Voicemail box reporting BUSY come here
exten => s-BUSY,1,NoOp(Extension is reporting BUSY and not passing to Voicemail)
exten => s-BUSY,n,Busy()
exten => s-BUSY,n,Wait(60)
exten => s-BUSY,n,Congestion()
If someone is calling the extension that has DND on they will get a busy tone back.


Actually, I modified dialparties.agi to allow certain callers to get through regardless of DND settings.

Do you know how to enable the special dial tone when DND is active?? It should give a special tone such as voicemail stutter tone when you have voicemail.