Do conferences support video?

Hey, I’m completely new to FreePBX. My predecessors set everything up and now I’m supposed to make video conferencing work. I don’t even know if conferences support video. The audio btw. works flawlessly, but no video. Would be awesome if someone could point me in the right direction! xD

Thx for the link! Though, we’re actually building an app for Android and iOs using React Native. Our app already supports audio and video calls. The only problem left is that we can’t get the video to work with conference calls.

Hi Linus, in addition to the option defcomllc provided, the standard conference application built into asterisk (app_conference) supports video if you connect with SIP or webrtc video clients.

https://www.asterisk.org/introducing-dana-the-stream-gatekeeper/ might give you some ideas of how to integrate your app.

1 Like

That looks interesting! Thx a lot!
We’re using PJSIP. I’m thinking that maybe the video actually gets sent along with the audio but we’re unable to detect it in React Native. Do you know if there is a way via FreePBX to find out if the video gets actually sent?

You can enable pjsip logging on the Asterisk console: pjsip set logger on to see whether the SDPs contain video streams. Otherwise you would just have to capture (wireshark, etc).

If you are using FreePBX to configure your conference rooms you will need to enable video support separately; e.g.

[email protected]:/etc/asterisk# cat confbridge_custom.conf 
[default_bridge](+)
;video_mode=follow_talker
video_mode=first_marked

video_mode options are documented at https://wiki.asterisk.org/wiki/display/AST/ConfBridge+Configuration , except this document does not include video_mode=sfu which you would want if you are doing multiple stream forwarding.

First of all thx so much for you help!
Yes, we’re indeed using FreePBX to configure our conference rooms.
When I run /etc/asterisk# cat confbridge_custom.conf on our server I get this -bash: /etc/asterisk#: No such file or directory. But we do have this directory /etc/asterisk/. I’m able to cd into it. Do you know what I’m doing wrong or do you know if it’s possible to change these settings via the FreePBX interface?

Sorry I wasn’t clear. What I meant to show is that you need to add video settings in that custom config file.

Edit /etc/asterisk/confbridge_custom.conf and put the heading

[default_bridge](+)

followed by the video_mode= you want to use.

After you edit a custom file you need to reload FreePBX by typing fwconsole r at the root shell.

Ahh, that makes sense!

I’ve added those three lines:

[default_bridge](+)
video_mode=follow_talker
video_mode=first_marked

Then I reloaded FreePBX with fwconsole but still no video in conferences.

I’ve also added video_mode=sfu and reloaded but no success.

Also, I ran pjsip set logger on on the server but it can’t find the command pjsip. I’m probably running it in the wrong terminal. Sorry, I’m really new to this…

Pick one mode, based on what you want to do (I am guessing SFU is probably what you want).

That command is issued from the Asterisk console, not the root shell. asterisk -r to start the asterisk console.

Pick one mode

Ooops, my bad :sweat_smile:

Hm, accessing the Asterisk console doesn’t work unfortunately. I get -bash: asterisk: command not found

It should be in the root user’s path.

1 Like

Asterisk is normally at /usr/sbin/asterisk thus echo $PATH would need to have /usr/sbin in it.

How did you install FreePBX/Asterisk ?

As what user are you running that command ? ( whoami will say.)

Even more, what version of Asterisk are you using? Some video capabilities especially sfu are not present in older versions.

Thx so much for your help guys! Sorry for answering so late! I got really sick and didn’t even turn on the computer yesterday.

@dicko That was a good hint! I should have run it with sudo :grin:
Judging from the documentation of my predecessors they used curl to install Asterisk:

$ sudo curl -O
http://downloads.asterisk.org/pub/telephony/asterisk/asterisk-16-current.tar.gz

@PitzKey We’re using version 17.9.0

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.