1st posting.
It looks like I’ve corrupted my DNS settins. Now when I try and add a DNS address (to the DNS Server List box), the system won’t retain the addresses on a reboot. The end result is that my SIP trunk is unable to register.

PBX Firmware: 2.210.62-5
PBX Service Pack:

Any idea’s.

Your DNS settings will be not honored if you use DHCP, the DHCP server will (at least should) supply that for you, if you use (as you should) a static address and network, then the settings in /etc/resolv.conf will be used.

I tried to ping www.store.freepbx.com but failed.
when i ping www.freepbx.com request timed out
so i did some reading here http://www.computerworld.com/s/article/9020261/Fix_your_DNS_problems
to Check my HOSTS file has this

localhost name resolution is handled within DNS itself. localhost

::1 localhost

//when i run ipconfig /all my DHCP SERVER AND DEFAULT GATEWAY IS
/when i auto configure sip settings it populates a static server address which fails a ping test however pings successfully/

and last but not least am i wasting my time editing the host file in windows
7 of the romote pc or could this be causing the problem when i
get the error below when i try to auto config sip settings?

is there a way to bypass this auto config sip i’ve got two weeks stuck on this

noserver: This module can not reach the server to obtain your account information. If you can navigate to https://store.freepbx.com from a browser then there is an issue with your firewall or DNS resolution. If this is a first time install you might be able to reboot to rectify the issue. If you have an aggressive firewall with content filtering or equivalent, you may have to disable that feature for this server or white list the store.freepbx.com site if possible.

Hi, I would simply assign a static IP and set your valid DNS in /etc/resolv.conf

Problem solved!

You can also add static nameservers in /etc/resolv.conf