Distinctive Ringing Polycom SoundPoint 450

I’m currently running FreePBX 12.0.1rc25 and using Polycom SoundPoint 450 phones.

I’m trying to set up distinctive ringing based on incoming routes. I’ve looked around and found a few posts that mention changes to sip.cfg and use Alert Info to change the ringer depending on the incoming route.

I’ve made the changes that this post ( http://pbxinaflash.com/community/index.php?threads/polycom-alert-info-distinctive-ring.11261/ ) mentions but I’m not having any luck getting it to work. I was wondering if anyone else has set this up (using this method) or if anyone has any suggestions for other methods that have worked.

Solved it.

This post mentioned that the alert info had to be defined (specifically for Digium phones but I figured the story was the same, the characters are slightly different). Doing a bit more research I found this post on Polycom’s forums that gave an example of defining the alert info for Polycom phones. I put the two together, modified a sip.cfg file defining the alert info. After applying the changes, putting the alert info in my inbound route and rebooting my phones I now have distinctive ring.

Do you mind sharing what you changed in your sip file? I have also been trying to get this to work.

That is defining the ringer as it shows on polycom’s site

This is the alert info

Then in the alert info on the inbound routes i tried and it didn’t work, just the normal low trill. Any ideas? @bill_m_911

Here’s what I’ve been using. Beeble hasn’t worked for me (yet) but all the others are. I still have a ways to go to finally “resolve” this because when I reboot my phone(s) I have to reapply the new .cfg file. I chopped off the top part of my sip.cfg before posting (so the rest would show up).

<feature feature.urlDialing.enabled="0" feature.directedCallPickup.enabled="1" feature.enhancedFeatureKeys.enabled="1" feature.presence.enabled="{$presence}" />
<call call.directedCallPickupMethod="legacy" call.directedCallPickupString="**" />
	  <se.rt.custom1   se.rt.custom1.name="Silent"               se.rt.custom1.ringer="ringer1" />
	  <se.rt.custom2   se.rt.custom2.name="Low Trill"            se.rt.custom2.ringer="ringer2" />
	  <se.rt.custom3   se.rt.custom3.name="Low Double Trill"     se.rt.custom3.ringer="ringer3" />
	  <se.rt.custom4   se.rt.custom4.name="Medium Trill"         se.rt.custom4.ringer="ringer4" />
	  <se.rt.custom5   se.rt.custom5.name="Medium Double Trill"  se.rt.custom5.ringer="ringer5" />
	  <se.rt.custom6   se.rt.custom6.name="High Trill"           se.rt.custom6.ringer="ringer6" />
	  <se.rt.custom7   se.rt.custom7.name="High Double Trill"    se.rt.custom7.ringer="ringer7" />
	  <se.rt.custom8   se.rt.custom8.name="Highest Trill"        se.rt.custom8.ringer="ringer8" />
	  <se.rt.custom9   se.rt.custom9.name="Highest Double Trill" se.rt.custom9.ringer="ringer9" />
	  <se.rt.custom10 se.rt.custom10.name="Beeble"               se.rt.custom10.ringer="ringer10" />
	  <se.rt.custom11 se.rt.custom11.name="Triplet"              se.rt.custom11.ringer="ringer11" />
	  <se.rt.custom12 se.rt.custom12.name="Ringback-style"       se.rt.custom12.ringer="ringer12" />
	  <se.rt.custom13 se.rt.custom13.name="Low Trill Precedence" se.rt.custom13.ringer="ringer13" />
	  <se.rt.custom14 se.rt.custom14.name="Ring Splash"          se.rt.custom14.ringer="ringer14" />
1 Like

Thank you very much, everything is working so far.

If you need to reboot your phone you may need to reapply the changes for distinctive ring. I’ve rebooted mine and they revert back to defaults. YMMV though, for all I know there’s something different I need to do to make the change stick.

I tried the reboot that everything has stuck. Are you still having an issue with yours not staying? Are you using the commercial endpoint manager? Below is the software version on my phone for reference.

Polycom IP 450

UC Software 4.1.085402
BootROM Software