FreePBX | Register | Issues | Wiki | Portal | Support

Distinctive Ring via alert_info - Grandstream GXP1630 Phone


#1

First and foremost, I’ve searched throughout the forum for hours trying to find a solution before posting–so forgive me if this is a duplicate topic.

I’m trying to invoke a distinctive ring tone for a particular inbound route using ‘alert_info’ function. All phones on this ring group are Grandstream GXP1630. I’ve tried dozens of iterations of syntax trying to get this to work–but I’ve had zero success. Has anyone implemented distinctive ringtones as described utilizing only the settings within FreePBX ‘Inbound Routes–>Settings–>Alert Info’ on Grandstream phones? I’ve tried to research this directly with Grandstream programming guides/forums, but have again come up empty handed.

-jG


#2

Does anyone know a resource or consultant for hire that could help me with this?


#3

See http://www.grandstream.com/sites/default/files/Resources/gxp16xx_administration_guide.pdf , p.44, Alert Info text. Set that to match the Alert Info you set in the Inbound Route.

If you have trouble, see whether setting Alert Info in the Ring Group works. (If so, you’ll need to set up a different Ring Group that has the same extensions but different Alert Info, pointed to by the ‘special’ Inbound Route.)


(Matthew Jensen) #4

I had trouble setting this up on my GXP-2170s, however I finally figured out that you have to place this whole string into the alert info box in freepbx:

<http://127.0.0.1>\;info=external

And within your phone, in the distinctive ring section, you place the string after the = into the appropriate place. In this case, the string would be “external” (without quotes).

Here are the pictures of the settings in FreePBX:

Settings in the Grandstream:

This works for me.


#5

Genlemen–thank you for your help. I believe I’ve had a bit of a breakthrough after both of your suggestions.

I now am able to get a distinctive ring on the phones using the Alert Info: <aitchteeteepeecolon//127.0.0.1>; info=priority

Strangely enough, I’m unable to edit the base file for the phone configs

Per Grandstream’s documentation P1488 = priority and P1489 = 1 should yield a Custom Ringtone 2 on Alert Text ‘priority’.

When you actually change the settings manually and export the device configuration, you can see that the P1488/1489 flags are being modified–however, when I change the base file and rebuild config and update my phones through FreePBX, the change is not being made within the headset after reboot. I’ve got several other custom basefile modifications that continue to work just fine. It’s possible I need to report a bug.


(Tony Lewis) #6

Not sure a big report will help. If other base file changes are applying to the phone that shows bare file edit is working. Would appear it’s something in the phone not applying it. I would start with reviewing the config file and see if your changes are shown.


#7

Tony–I understand your sentiment. It’s possible that the modified config is not saving in the current version of Endpoint Manager. My prior changes could have been made with a previous software version and were successfully stored. The fact that the handset is exporting a modified config file with the P1488/1489 lets me know I’m on target for that being the correct modification.


(Matthew Jensen) #8

Using those 2 P values, I am able to configure distinctive ringing on my 2170s. Maybe try downloading the EPM config from the server and seeing if those P values are changed there. If not, that would seem to indicate more of an EPM problem, if they are showing there, and your phone is still not grabbing it, then it might be a phone thing.


#9

Will do once I can get to a SSH machine. Will report my findings.