Disconnecting call for lack of RTP activity in 31 seconds

Hey guys new to the forum needs some help , migrated to fpbx16 6 months now and still working out the kinks , tried Pjsip apparently no compatible with FPL trunks ( 1 have 4 to them ) switched over to ChanSip got everything working except for outbound call drops after 15mins .
Tried every option that was provided on the forum , need a closer look at my situation in case i missed something .

Please any help is appreciated .

Regarding pjsip and FPL, see

and the thread linked from there.

You can confirm with pjsip logger if the bug is still there, or if your issue is different.

For the call drop issue, the usual problem is a NAT association timeout. If that’s the case, you can confirm that with BYE from the remote end: Make a test call to your mobile. A few seconds after answering, hang up the mobile and confirm that within a second or two, the calling phone shows the disconnect. If not, we will troubleshoot that first. If the test succeeded, make another test call to your mobile, answer it and keep the connection up for 13 to 14 minutes. Now hang up the mobile and see whether the calling phone shows the disconnect. If not, you have a timeout issue.

Confirm that your trunk configuration has
any SIP ALG in your router/firewall is disabled, you’re not doing any funny stuff like forwarding a different external port to the port that chan_sip Bind Port is set.

If you still have trouble, post router/firewall make/model. If it doesn’t have a public IP address on its WAN interface, post modem make/model and ISP.

By bug you mean on the fibernetics side, right?

Sure, though the pjsip guys could add an option to send the From User as a workaround for buggy peers.

Bro Nialed It… after Months of searching the forums/web finally the solution , i was missing the line " fromuser= ** " in the outbound peer details. strange now that i think about it should have been the in the first place.

Hope the help others . Solved !!

Sorry, I grabbed a chan_pjsip trunk trace by mistake. However, Asterisk follows RFC and not having a user in the contact is not only acceptable, it is common place. If Fibernetics is having an issue with it, it’s on their side.

The other thing could be that dropping an incoming call after 31 seconds could indicate a NAT issue as Asterisk will drop a call after 30 seconds of not receiving audio. So at 31 seconds, call is dropped. Probably should confirm simple things like NAT issues and verifying audio is actually streaming.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.