DISA's dialing not working (solved)

Note: I’m french and my english is not perfect. Hope you’ll understand my problem. :slight_smile:

Hello FreePBX users,

I just set up DISA for inbound calls (at the moment). The problem is when i call from the outside world, there’s the DISA’s dial tone as expected, but when i try to dial a number (whatever it is) it looks like that it’s totally ignored.

I used Wireshark and i can properly hear the sound of the dial tones received from my SIP provider to my server.

I read about 10-12 different webpages, some from this forum, some of them were outdated and i’m still in trouble.

Any suggestions please ? Thanks in advance ! :wink:

First, figure out if it’s a DTMF problem or a DISA problem - set your inbound route to a simple IVR with options 1,2 and 3 and then call it and make sure you can select an option.

Assuming you can, then we know your box is decoding DTMF correctly and you can move on to the DISA - What exactly are you trying to dial? I assume (actually I really hope!) that you have restricted who and how the DISA can be accessed - at the very least a list of allowed Caller-ID’s and no less than a 4-Digit PIN (6 would be better) - Someone making calls through your system can get VERY expensive.

Test the DTMF and then we cal look at some console captures to see what is going wrong.

2 Likes

I set up an IVR with a few options and i can’t reach one of them (like it happend with DISA). Looks like it’s DTMF problem.
And the same thing happens with Wireshark where i get the dial sounds in the audio sample.

What can i do to fix it ?

I set up a password on DISA but the same thing happened, so nobody can use it at the moment x’)

Here is the asterisk log file when i called the IVR from the outside:

Post your SIP trunk settings (with passwords and logins removed) - My guess is they are sending you Info and you are looking for Inband, or vice-versa - they are sending Inband and you are looking for Info.

1 Like

Here you are :wink: :

[freephonie]
allow=all
context=from-trunk
fromdomain=freephonie.net
fromuser=**********
host=freephonie.net
insecure=port,invite
qualify=yes
secret=**********
type=peer
username=**********

add

dtmfmode=inband

quick goole search with “freephonie+dtmf” show they are using (probably) inband.

If that does not work, the other dtmf option you can try and set (inbound) are

dtmfmode=rfc2833 or info

1 Like

IT WORKS ! Wonderful !

I was suspecting the DTMF and used to test different DTMF by changing “SIP DTMF Signaling” in ‘Advanced Settings’ but it changed nothing… ^^’’

Thank you guys ! :smiley:

you might also want to test the
dtmfmode=rfc2833

The difference between inband and rfc2833 (both inband ) is in their sensitivity to network problems and the way it is transmitted and bla bla… long story short?

If you use codec other the G711 or not sure - prefer using rfc2833 (which should also work in your case I believe) - which is considered the “standard”

Good Luck!

1 Like

I tested rfc2833 (and info by the way) and it doesn’t work. :sweat_smile:

Thanks for the short story ! :wink:

1 Like