Disabling voicemail instructions when leaving messages

Dumb question but,
I’m trying to remove Allison’s instructions, “Please leave a message after the tone, when done hang up or press #” that plays after the users greeting. I really only need to disable this for one mailbox. I thought I remember inside of the Voicemail Admin module, general, you could disable voicemail instructions but I’m not seeing that. (FreePBX 13.0.190.11) Voicemail Admin, 13.0.53.3

I tried enabling VMX for this extension but with VMX enabled the “beep” never played, it appeared to wait for a 1, then played the instructions, beep, and then began recording.

I’m sure this is easy to figure out but I just can’t seam to find the right option.

I wouldn’t mind disabling it system wide but I couldn’t find that option either.

When editing the extension, under the voicemail tab, there is an option labeled “Voicemail Instructions”. Have you tried disabling that one?

Settings>Voicemail Admin>Dial Plan Behavior> Disable Standard Prompt

2 Likes

In the extension tab, I have dialed the “voice mail instructions” from the VMX options. However this seams to cause the greeting to be played then a pause waiting for 1 digit and then the beep. Trying to eliminate that pause.

Dialing from 5331 to 2000

– Executing [[email protected]:24] Answer(“SIP/5331-000022af”, “”) in new stack

0x7f1e5c465bd0 – Probation passed - setting RTP source address to 10.255.100.22:50020
– Executing [[email protected]:25] Read(“SIP/5331-000022af”, “ACTION,/var/spool/asterisk/voicemail/default/2000/unavail,1,skip,”) in new stack
– Accepting a maximum of 1 digits.
– <SIP/5331-000022af> Playing ‘/var/spool/asterisk/voicemail/default/2000/unavail.slin’ (language ‘en’)
– SIP/515-000022ae answered DAHDI/i1/5179240439-2838
– User entered nothing.
– Executing [[email protected]:26] GotoIf(“SIP/5331-000022af”, “0?checkopt”) in new stack
– Executing [[email protected]:27] NoOp(“SIP/5331-000022af”, “Timeout: going to timeout dest”) in new stack
– Executing [[email protected]:28] Set(“SIP/5331-000022af”, “VMX_OPTS=s”) in new stack
– Executing [[email protected]:29] GotoIf(“SIP/5331-000022af”, “1?dotime”) in new stack
– Goto (macro-vm,vmx,33)
– Executing [[email protected]:33] Goto(“SIP/5331-000022af”, “,dovm,1”) in new stack
– Goto (macro-vm,dovm,1)
– Executing [[email protected]:1] NoOp(“SIP/5331-000022af”, “VMX Timeout - go to voicemail”) in new stack
– Executing [[email protected]:2] VoiceMail(“SIP/5331-000022af”, “[email protected],s”) in new stack
– <SIP/5331-000022af> Playing ‘beep.ulaw’ (language ‘en’)
– Recording the message
– x=0, open writing: /var/spool/asterisk/voicemail/default/2000/tmp/PYCEbo format: wav, 0x7f1e24cd9c88
– User hung up
== Spawn extension (macro-vm, dovm, 2) exited non-zero on ‘SIP/5331-000022af’ in macro ‘vm’
== Spawn extension (macro-exten-vm, s, 23) exited non-zero on ‘SIP/5331-000022af’ in macro ‘exten-vm’
== Spawn extension (ext-local, 2000, 2) exited non-zero on ‘SIP/5331-000022af’
– Executing [[email protected]:1] Macro(“SIP/5331-000022af”, “hangupcall,”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/5331-000022af”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] ExecIf(“SIP/5331-000022af”, “0?Set(CDR(recordingfile)=)”) in new stack
– Executing [[email protected]:4] Hangup(“SIP/5331-000022af”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/5331-000022af’ in macro ‘hangupcall’
== Spawn extension (ext-local, h, 1) exited non-zero on ‘SIP/5331-000022af’

Unless I’m misunderstanding you (quite possible), it sounds like you don’t really want/need vmx. If you turn that off then disable the voicemail instructions, what is that doing/not doing that you want changed?

That’s what i’m trying to do. My issue is that I can’t find how to disable the voicemail instructions. Either by extension or in the entire system.

Settings>Voicemail Admin>Dial Plan Behavior> Disable Standard Prompt

1 Like

That did it. Thanks. I knew it was something was overlooking.