Disable ring on line 2 when phone is busy


(SKP) #1

We are using FreePBX 13.0.191.11 along with Grandstream GXP-1625 phones in our campus.

When a phone (say extension A) is busy on another call and someone (say B) dials the extension A, the phone A will ring on line 2 and user B will hear the ring and it seems that A is not picking up the call.

I have disabled Call waiting on extension A but same issue persists.

I am not very much familiar with FreePBX, so I would appreciate if someone can help me out here…

Thanks.


#2

There is a Call Waiting setting for the extension in FreePBX. When set to Disable, if the extension is in use calls should go immediately to voicemail, or give a busy signal if VM is not enabled.

There is also a Disable Call Waiting setting in the phone config. When set to Yes, if the extension is in use calls can ring on other devices with the same extension number, do follow me (if certain settings are in force), etc., but would usually behave similarly.

Which did you try? If you still have trouble, paste a log of a failing call at pastebin.freepbx.org and post the link here.


(SKP) #3

Hi Stewart1… Thanks for your reply.
Actually Call Waiting on Extension is already disabled and Voice Mail is also Disabled.
But when extn A is on another call, the same device rings on line 2 when it is dialed from extn B.
Regarding logs, I did not understand “failing calls”. The call is actually getting through and the phone is ringing.

Thanks.


#4

Sorry, I meant a call that should have given a busy signal but rang line 2 instead.