Disable FreePBX Support in GUI for simple users

Dear Fpbx.

I made some custom users for a customer.
I disabled a lot features for this simple users, just to make it easy.
The only thing, that I can not disable is in the Gui menu Support: FreePBX Support.
I can select it with creating/editing users, but it still shows afterwards.
Support tabt also contains Asterisk Logfiles.

How can I hide/disable this TAB?

I would appreciate your answer very much,

With regards,
Bas

The menu entry for FreePBX Support is just a module that you can uninstall. Go to Module Admin. It is named “Online Support” in the “Support” section.

Hi Bodywave,

Thanx for your answer!,
I already did uninstall, but there is another tab called ‘Freepbx Support’ wich I can not disable.
Greets Bas

I would also like to be able to do this. A customer of ours does not want anyone accessing the internet through the phone system.

How can this selection be disabled or removed?

I have looked at every file in /html and cannot find this.

Must be SUPER DUPER top secret info, since no one wants to divulge how to disable.

The logos can be stopped through system admin but nothing on the drop down menu selection?

What are you referring to. Please send a screenshot of what you are referring to?

It’s in the Admin drop down menu. “FreePBX Support” button.

There are two ways you can remove the “FreePBX Support” men item that come to mind.

First, in Administrators don’t give them access to that. If you are doing that and access is still being provided, then file a bug so we can have a look.

If you want to get rid of that tab for all users, you can use the freepbx_menu.conf file to remove it in the same way you can completely re-organize your menu structure. You need to enable this from Advanced Settings or that file will be ignored.

Just put in an entry in that file that looks like:

[wiki]
remove=Yes

“wiki” happens to be the internal “raw name” of that display page, you can see it in core’s module.xml file.

That worked perfectly! Thanks!

Changing info in freepbx_menu.conf.

Disabling in Administrators didn’t work.

Please file a bug so we don’t forget to have a look at why you can’t disable that in the Administrators configuration page.

What he is trying to do is located in a XML file called
modules.xml
This file is located under /admin/modules/core

Please edit that file and modify the line …

Good Luck!

1 Like