Disable FOP in 2.10

How does one disable FOP in 2.10? Remove the framework module?


Thank you. After removing and rebooting, that did the trick.

Hi, I also wanted to just remove FOP as it is mostly unsupported in 2.10 and it was printing many error messages to the console when it was installed.

After removing the FOP module, I still saw the following errors when running amportal:

Missing security_code in op_server.cfg! at /var/www/html/admin/modules/fw_fop/op_server.pl line 592.

Renaming the FOP hook script so it is not automatically loaded prevented these.

mv /var/lib/asterisk/bin/freepbx_engine_hook_fw_fop /var/lib/asterisk/bin/norun-freepbx_engine_hook_fw_fop 

Tim Miller Dyck

Don’t rename scripts. Use advanced settings to disable FOP or install FOP2 from yum.

Hi SkykingOH, thanks for your tip. I am hunting through Advanced Settings to find a GUI switch to completely disable FOP and am not seeing it. Is this the section to which you are referring?

Settings > Advanced Settings

  • Display Hidden Settings set to “True”
  • Display Readonly Settings set to “True”

“Flash Operator Panel” section only displays these three options:

  • FOP Web Root Dir
  • FOP Password
  • FOP Sort Mode

Tim Miller Dyck

I can confirm that on a 2.10 system that was upgraded from a fresh 2.0.0.x distro install that the only fields on the page are

  • FOP Web Root Dir
  • FOP Password
  • FOP Sort Mode

since FOP1 is mostly useless, I am trying to upgrade to fop2. How do I disable fop1 with 2.10 ?
I tried adding


in amportal.conf
but that didn’t help either.

Anyone get this disabled?

I’ve made changes above and restarted amportal and the FOP link still lets anyone right in.

Yes. Remove the module in the module admin. Doing this then rebooting worked for me.

gregc has already said this (twice at this point), but he didn’t emphasize the reboot strongly enough. I made the same mistake as brookz – I assumed that amportal restart would accomplish the same as “reboot” but that’s not the case here. I tore my hair out for 2 hours until I simply rebooted. The errors stopped immediately upon reboot.

Nope, same thing.
rebooted server, load root freepbx site and 3 choices remain.

Voicemail & Recordings (ARI)
Flash Operator Panel (FOP)
FreePBX Administration

FOP just loads empty FOP page