Disable Dhadi Module

Hi all,

When dahdi module can’t keeps configuration on startup for all configuration that has made via CLI, people almost suggest to disable this module after configuring it, honestly i never test this. Yersterday i made a test by disable the dahdi module under admin /module/connectivity, when done i logged in on FreePBX but the dahdi module was no longer appear under Connectivity Tab that will allow me to verify the status of the existing cards (Analog - Digital), which is normal . However, a lot of configuration will be set on this module for the cards that will allow inbound and outbound calls, I wonder if by disabling this module — It that will not gonna block both inbound and outbound calls.

Look forward to your reply.

Thanks !

Are you using any cards? if not, you can ignore that. Yes, there is a default trunk by dahdi, if you use sip trunk, you can use the sip trunk and do not select dahdi.


If you disable the module you will have to manually configure DAHDi or keep the last configuration file it made before you disabled them.

There were problems with that module in the past but right now everything works fine for me with it active.

Have a nice day!



I don’t know about the OP but I use DAHDi but I have no DAHDi trunk, my modules are all FXSs…

(no FXO at all so no DAHDi trunk, my trunks are all SIP…)

Have a nice day!


If you use FXS, you have to use dahdi modules. You do not need to worry the trunk from dahdi/FXO/E1 if using FXS only.

There are three different “modules” here, so I’d like to point out that this statement isn’t 100% right. I’m hoping this is just a language issue, or maybe it’s because I’m a little pedantic.

When using many DAHDI cards, there are FXS and FXO modules that you can install and use. These are required for POTS phones to work or for your system to connect to a POTS network.

When using DAHDI in Asterisk, there is a loadable module that is required for the system to talk to the hardware. This is also required. The DAHDI software used to manage the cards is the user interface to the cards and allows them to talk to Asterisk and configure them.

In FreePBX, if you are DAHDI trunks or cards, there is no REQUIREMENT to manage these in FreePBX. You can easily (see disclaimer) set up and use DAHDI modules using the loadable module and do everything from the command line. Once set up, the system simply needs to have the Asterisk DAHDI interface software installed so that the system can talk to the cards.

If the DAHDI module in FreePBX works well with your DAHDI configuration, then by all means install and use it. If it does not, then by all means remove it from your FreePBX installation. Having said that, if you do find something in the FreePBX module that doesn’t work for you, document what you found in a ticket and let the developers know. While the working relationship between Digium and Sangoma is strong, it isn’t predatory or pernicious, so you might see some movement in making the FreePBX module work for you as well. Also, as always, remember that this is open source, so if you have some code changes, fill out the “I want to help out” form and submit some code.

Disclaimer - “easily” is a bald-faced lie. DAHDI is a PITA to get configured and working the first time. If you use anything but Digium hardware, the FreePBX module may not (or may) work well with your cards. As such, there are times when using the FreePBX module to manage the Asterisk loadable module to talk to your DAHDI card with FXS and FXO modules on it is not required,

Thanks All.

I have disabled the Dahdi Config Write, under module admin and both Digital and Analog cards keep config even after a reboot.

It seems it works that way, but at eah login in Coonectivity the Dahdi helper window prompt me to enable or disable the module .

As my granddaughter seems to be so fond of saying: “Suck it up, buttercup.” :wink:

Yeah, you’ll get the warning, and you know why you’re getting it. Better to have a whiny system that works than a whiny complaining about his phones not working. :smile: