Directory not playing voicemail greeting and does not list users unless included in default directory (mass add doesn't work)

I am running 1.814.210.58-2 of the FreePBX distro. The directory module is v2.10.0.10. I did a backup/restore from one PBX to the other. The voicemail recordings came over fine, I get my busy/unavailable message when I call myself and can download and listen to my greeting.

When I add everyone to the directory and set it as the default it adds everyone but when I call in and type my letters in, it says I don’t exist.

If I go to my extension and include myself in the directory it does play find me but only spells my name out, it does not play my greeting (/var/spool/asterisk/voicemail/default/extension/greet.wav

I have unisntalled/reinstalled the module

I deleted the directory and recreated then mass added everyone.

I deleted the directory and only included myself from the extension which added me to the directory.

Looking at the asterisk database, it shows me in there and says it should play my voicemail greeting. I have also tried changing it to text to speech and even another IVR message and it still just spells out my name.

mysql> select * from directory_entries;
| id | e_id | name | type | foreign_id | audio | dial |
| 3 | 1 | | user | 1122 | vm | |

I also tested this on the source system that was backed up and it does not play my recording either so I don’t think it has to do with the backup/restore.

It also seems to remove the default directory setting if I make any directory changes in Firefox. Chrome lets me set the default directory though.

I am still on, possibly the bug that was fixed in

I just tried again and can’t get it to play their greeting. I added all users from the directory. I set that directory to the default. I tried excluding the user then including the user again. I verified that greet.wav existed for the user and downloaded it and listened to it.

The MySQL database shows audio as vm, below are the permissions maybe they are not good?

ls -l /var/spool/asterisk/voicemail/default/3050
total 316
-rw-r–r-- 1 asterisk asterisk 138284 Oct 31 10:50 busy.wav
-rw-r–r-- 1 asterisk asterisk 27244 Oct 31 10:49 greet.wav
drwxr-xr-x 2 asterisk asterisk 4096 Nov 2 11:59 INBOX
drwxr-xr-x 2 asterisk asterisk 4096 Nov 2 11:59 Old
drwxr-xr-x 2 asterisk asterisk 4096 Nov 1 14:09 tmp
-rw-r–r-- 1 asterisk asterisk 130924 Oct 31 10:49 unavail.wav
drwxr-xr-x 2 asterisk asterisk 4096 Oct 31 10:49 Urgent


I am not seeing the problem and just tested it

This problem is affecting a new install I just completed.
The directory plays the letters rather than the recorded name.
Asterisk 1.8.17
FreePBX 2.10

I just worked on this again due to a management request and am still having the same issue. Anyone have any suggestions.

In your IVR Entries, are you using the choice of Directory or Phonebook Directory?

I had a similar problem with the text to speech, and this wasn’t corrected until I changed the entry from Phonebook Directory to Directory. I then had to choose the customer entry I made under Applications > Directory.

Thanks for the reply. My IVR is using the directory I created rather than the phonebook entry.

Did you ever figure this out. I am having the same problem.

Let me know

Thank You.

I believe it is a bug. I plan on upgrading to FreePBX 2.11 and CentOS 6.4 here in the near future and am hoping the issue is resolved in that version.

I had the same problem, which was occurring because I was just transferring from the IVR to the 411 Feature Code, instead I just needed to create an actual directory and add my member extensions (there you can specify whether you want text to speech, use the voicemail greeting, and more).