Digium Wildcard TE133F UK BT ISDN 30 E1 configuration

Hi. I am installing a free PBX using a Digium Wildcard TE 133F card and the latest version of FreePBX. The card is auto detected in dahdi config the card shows up as a Digium Wildcard TE131/TE133 card 0 [1]

However the settings for this card are set by default as a T1 and not as E1 as required for UK BT ISDN30

The closest matching card I can see in Modprobe Settings is the wcte13xp however the config options for this card look they are for a FXS card and not a PRI card.

If I set this to UK etc save the settings and reboot the card is not longer listed for further configuration.

Can somone tell me what the correct way is to configure a Digium Wildcard TE 133F is for the UK and more specificaly for a BT ISDN30 PRI E1?

Many thanks


Thanks for the reply.

The issue is /etc/modprobe.d/dahdi.conf is overwritten by freepbx


Do NOT edit this file as it is auto-generated by FreePBX. All modifications t$

this file must be done via the web gui. There are alternative files to make $

custom modifications, details at: http://freepbx.org/configuration_files $


I am expecting modprobe wcte13xp default_linemode=e1 is set in the GUI of freepbx somewere.

How do you set the card to be e1 in freepbx if the config file is overwriten by the gui?


Then you need an answer from someone that uses the dahdi helper module.

anyone know how to set digium TE133 cards to E1 config in FreePBX when FreePBX overwrites the config files?


Message from Digium

“Ok, the only way I have found to keep freepbx from overwriting the files is to disable the dahdi module in freepbx. Unfortunatly I do not know how that is done because we dont support freepbx itself, just Asterisk. You may need to contact freepbx but this is the only solution I have heard of.”

Under “Connectivity” go to “DAHDI Config”.
On the far right there is a “Settings” area. Choose “Modprobe Settings”.
In the box that appears, there should be a selection for “wcte13xp” in the “Module Name” dropdown.
At the very bottom, “Other Modprobe Settings” add “default_linemode” = "e1"
Set “Opermode” equal to “UK”

That will make FreePBX always find the card as an E1. Ask me how I know :smile:

You should also set the tone settings to “UK”.

How do you know?

I think I tried this but when I do that the card is removed from the list of available devices to configure. Do you have the exact same card?
Do you have a good config for connecting to a BT ISDN30?


I just went through the exact same issues about a month ago. Yes, connected a TE133 to a BT ISDN30e. At one point, I the card disappeared completely from the hardware configuration and it took me a bit to figure out how to get it to re-discover without re-installing the whole damn server. I’ll look at it in a bit and try to come back to you today.

This is how I have mine configured.

Many thanks for this. Much appreciated. I’ll give this a go over the weekend.


Yes tried this and it looks a lot better.

How have you configured the card to use it with a BT ISDN 30 with only 8 channels active?


Yes, well, actually 10. You can just create a separate group with the first 8 channels in your case, and then busy out the second group that has the remaining channels. Only use group 1 in your outbound and you should be good.

OK so If you have 10 active channels you put the first 10 in group 0 and the rest in group 1 excluding channel 16.

I have filled out the config but dahdi won’t load. I get the following error message in the asterisk console

-- Remote UNIX connection

[2015-06-21 16:28:15] WARNING[2901]: loader.c:607 ast_unload_resource: Unload failed, ‘chan_dahdi.so’ is not loaded.
– Remote UNIX connection disconnected
– Remote UNIX connection
[2015-06-21 16:28:15] WARNING[2903]: pbx.c:7327 ast_register_application2: Already have an application ‘DAHDISendKeypadFacility’
[2015-06-21 16:28:15] WARNING[2903]: pbx.c:7327 ast_register_application2: Already have an application ‘DAHDISendCallreroutingFacility’
– Registered libwat
== Parsing ‘/etc/asterisk/chan_dahdi.conf’: Found
== Parsing ‘/etc/asterisk/chan_dahdi_general.conf’: Found
== Parsing ‘/etc/asterisk/chan_dahdi_general_custom.conf’: Found
== Parsing ‘/etc/asterisk/chan_dahdi_channels_custom.conf’: Found
== Parsing ‘/etc/asterisk/chan_dahdi_groups.conf’: Found
== Parsing ‘/etc/asterisk/chan_dahdi_additional.conf’: Found
[2015-06-21 16:28:15] WARNING[2903]: chan_dahdi.c:4774 dahdi_open: Unable to specify channel 1: No such device or address
[2015-06-21 16:28:15] ERROR[2903]: chan_dahdi.c:13123 mkintf: Unable to open channel 1: No such device or address
here = 0, tmp->channel = 1, channel = 1
[2015-06-21 16:28:15] ERROR[2903]: chan_dahdi.c:18109 build_channels: Unable to register channel ‘1-10’
– Remote UNIX connection disconnected

Any thoughts?