Digium Phones STATUS


#1

Wierd problem, seems to be connected to our recent update to FreePBX 12.0.1rc28 (at the least the timing is there).

When users try to set their phone in DND, it goes in to “extended leave” instead, with the little plane icon.

Tried resetting to factory default and reconfiguring, it does the same.

Not a big issue but I’d like to fix it.

We user Digium Addons v2.11.0.4 and the firmware on all phones is 1.4.2.0


#2

Anyone can help ?

In the meantime, with further testing, I noticed that all the statuses are messed up.

For example, if we try to put “Prefer CHAT” it displays the “Unavailable” icon.

Only the “AVAILABLE” status works right.


#3

There used to be a DIGIUM sub category here… but I can’t figure out how to post in there since the “new design” of this forum…

And now all my DIGIUM + FREEPBX questions don’t get any answer anymore…


(Malcolm Davenport) #4

What version of res_digium_phone (DPMA) are you using?

digium_phones show version

from the Asterisk CLI


#5

Digium Addons v2.11.0.4

Is that what you need?

I guess not because I had mentioned that in my original post…

How can I find out this info you’re looking for?


#6

Enter what Malcolmd said in the command line and you should see something like this.
Digium Phone Module for Asterisk Version 11.0_1.6.0


#7

Entering this in the BASH shell or in the CLI gives me this:

No such command 'res_digium_phone' (type 'core show help res_digium_phone' for other possible commands)

(Malcolm Davenport) #8

If you’re going to use the Linux CLI, run:

asterisk -rx “digium_phones show version”

If you’re going to use the Asterisk CLI, run:

digium_phones show version

We fixed some presence bugs in DPMA 1.7 related to the use of custom presence that resulted in something exactly like you describe - and we’ve got one that can show up in some cases that we’re going to address in the forthcoming 2.1 release.


#9

Got it:

Digium Phone Module for Asterisk Version 11.0_1.6.0

#10

BTW I don’t have any custom presence set up, unless FreePBX does that by itself.


#11

So I gave you the DPMA version… now what should I do ?


(Malcolm Davenport) #12

Put the current version in place instead of 1.6.0. The current version is 2.1.1.


#13

Hi malcomd

Thanks for your answer!

So I guess I can’t do that within the FreePBX GUI ??


(Malcolm Davenport) #14

Negative, the res_digium_phone.so (DPMA) Asterisk module cannot be upgraded from within the FreePBX GUI.


#15

Hi Malcom,

I followed the instructions here:
https://wiki.asterisk.org/wiki/display/DIGIUM/DPMA+Installation#DPMAInstallation-InstallationProcedure

Then:

CLI> digium_phones show version
Digium Phone Module for Asterisk Version 11.0_2.1.1

Rebooted the system, annnnnnnd : plane icons are gone !!!

Thanks :smile:


(Malcolm Davenport) #16

Yay :slight_smile: (some characters to reach the minimum)


#17

So it worked for a few days, and the planes came back.

Just checked and DPMA is 11.0_2.1.1, and firmware_1_4_2_0_package on all phones, I’m still getting the planes icons.

Any suggestion?


(Malcolm Davenport) #18

Give me some reliable steps to reproduce what you’re seeing. Otherwise, we’re just fishing for an edge case.


#19

Hi malcolmd

Sorry for the delay, I wanted to check a few things.

Now I’ve made full factory reset on ALL the phones

I don’t know how you could reproduce the steps but I’ll give you as much info as possible, if you need more info I’ll be happy to respond.

We’re using D40s, D50s and D70s.
As I said all of them have been restored to factory default then reconfigured by provisioning to FreePBX (with the DIGIUM add-on).

We’re using FreePBX 12.0.25 with Digium Addons 2.11.0.4
Firmware is downloaded in the Digium Addons modules (latest firmware_1_4_2_0_package)
All phones are configured to download latest firmware
DPMA version is 2.1.1 (latest)

Now ALL phones, whichever model they are, display a PLANE when we try to set the status to DO NOT DISTURB.

In fact, any status except AVAILABLE will put a PLANE icon and extended away status.

This is quite annoying because we do use the icons to see who’s just not available (DND icon) and who’s actually away for a while (plane icon)

We don’t have any custom status.


(Malcolm Davenport) #20

Howdy,

Great, now contact Digium’s Support department (www.digium.com/support) and be prepared to provide them with configs and such.

Cheers