Digium phones looking for the Wrong PBX Server IP


(Froglevelmc) #1

I recently bought a Sangoma FreePBX Appliance 40. I am new to this whole thing and not terrible familiar with phone systems short of online videos. Anyway I have set this thing up and and am having trouble getting some Digium D40 and D70 phones to connect. DHCP gave the device an IP of 192.168.100.139 and then changed it to a static IP of 192.168.100.7. The first phone I plugged into the network started looking for 192.168.100.139 (the wrong address).
I can manually set the IP in the phone and it finds all the available extensions. When I select one it looks like it is reconfiguring the phone and restarts. As soon as it restarted is starts looking for the wrong IP again. I have factory defaulted the thing and tried it again but it still does the same thing. Where is the phone getting that old IP from?

Ultimately, my intent is to be able to provision the phones with the endpoint manager. but when I try adding a phone with the extension mapping and save / reconfig / update nothing happens. I am sure there is a config mistake somewhere.


(Dave Burgess) #2

It sounds like the EPM has set it’s default server address to the original DHCP address. Note that if you are planning on using DHCP as a backup to the static IP address you set, you can set up a dedicated IP address for your system’s MAC address in the DHCP server

I don’t often use EPM, but I remember from the last time I played around with it that the address is stored in one of the config pages for EPM.

Also, remember that you have to completely restart FreePBX (“fwconsole restart”) for any kind of IP address changes to take effect. You may also need to rebuild the phone config files, since I believe the server address is stored in there.


(Froglevelmc) #3

Thanks,

I have looked and looked but have not seen it anywhere. I restarted fwconsole. The phone still says “contacting sip:proxy@192.168.100.139:5060;transport=udp”
I don’t see that IP in any of the settings on the PBX. Could there be something stuck in a config file somewhere? If so, I don’t know where that file would reside.

One other thing I did not mention. I had the Digium Phone Module installed prior to enabling the endpoint manager. Then I uninstalled the DPM. Could that have not cleared up completely. Where are all the config files and Modules stored in FreePBX…


#4

It really does sound like there’s a chance 192.168.100.139 is still set somewhere like you’ve suspected. You might have already checked all the possible spots, but just in case, do you get anything back if you try this from the console?

grep “192.168.100.139” /etc/asterisk/*

My first guesses would have been to check the address in the EPM’s DPMA settings, and Settings->Asterisk SIP Settings. You may have already checked those. Also, you may have already been doing this, but you’ll want to make sure you click ‘Apply Config’ or ‘fwconsole reload’ after making changes. I’m not sure if a ‘fwconsole restart’ alone covers the same actions.

I’d also try looking for that ip in any of the phone config files. For example:

grep “192.168.100.139” /tftpboot/*

Also in Endpoint Manager, if you modify the Digium template that you’ve mapped to the test phone, do the Destination and Provision Server Addresses look correct?


(Dave Burgess) #5

@froglevelmc because of the way that TFTP directories are often stacked, you might want to use

grep “192.168.100.139” `find /tftpboot -type f`

This will find all of the files (versus directories) that have the string in them starting at the /tftpboot directory. The same hack could be applied to the first grep, but it’s less of an issue.


(Froglevelmc) #6

[root@freepbx ~]# grep “192.168.100.139” /etc/asterisk/*
grep: /etc/asterisk/backup: Is a directory
grep: /etc/asterisk/digium_phones: Is a directory
grep: /etc/asterisk/keys: Is a directory

This is what get from the grep.


(Froglevelmc) #7

Returns Nothing


#8

When trying these search commands, are you copying and pasting from here? I just noticed the forum is replacing the double quotes with a fancy version that ruins the search if pasted as is in the command line. Also, you may have tried cynjut’s command with backticks, but it doesn’t appear on your post’s quote. Make sure those are included if they are weren’t when you tried.


(Froglevelmc) #9

I did copy the commands but they look correct in the console. Not sure what happened in the quotes.
Although, I am starting to wonder if the there may be some settings stuck in the phone I am testing with. I just got a different message on the phone after I added a second interface (192.168.100.3) and tried to connect to it about the global configuration password being wrong. Do you know how to get into these Digium phones I reset the factory defaults but it still seems like something is setup in them.


(Froglevelmc) #10

Now the phone is connecting to the 192.168.100.7 but I am get the message “Invalid credentials for proxy.” I’m gonna try a different phone.


(system) closed #11

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.