Digium phone - No audio through IPsec tunnel

digium
Tags: #<Tag:0x00007fafcdf58078>

(Phuketmymac) #1

Hello,

I am scratching my head on this.
Let me be honest I am complete newbie when it comes to VOIP and FreePBX.

I have managed to install FreePBX as a VM on my Proxmox server and set up an inbound/outbound SIP trunk to it.
I can call from the outside and leave a message which works. Voicemail is recorded and I can hear myself talking.

I have 2 small offices connected using an IPsec tunnel with 2 Mikrotik routers.
Please don’t ask me why but I have at the moment the Server in one office and the D60 IP phone into the other network. And that’s the only phone I have so far. The 2nd one is ordered and will arrive soon. Though I am staying in the 2nd office ATM.

The phone can register properly to the Server and ringing, picking up or hanging up the phone works.
However no sound whatsoever.

Since the SIP trunk is working fine and I can record audio from incoming phone calls, I believe the issue is only related to the Digium D60 not being able to send audio Data to the Server and vice-versa.
I guess you will tell me to bring that phone to the other office and try in the same network to rule out an issue with the phone itself and its setup.

It might be a simple config problem as this seems to be a very common problem, apparently mostly related to NAT traversal. But I am using an IPsec tunnel which should use routing only. Aren’t I right?!

I have btw followed a mikrotik forum post to disable the SIP helper on both Mikrotik firewalls. That did help with phone calls not terminating after someone would hang up.

I have played for hours if not days with the settings of the phone, directly from its Web UI or through the Digium Addon with no success.

So any idea guys?
Thanks!


#2

In Asterisk SIP settings, confirm that Local Networks has entries for the subnets of both offices. If you change this, you must restart (not just reload) Asterisk.

If this does not help, at the Asterisk command prompt, type
pjsip set logger on
and make a simple test call from the D60 to *43 (echo test).
Paste the resulting Asterisk log (from Reports->Asterisk Logfiles) at https://pastebin.freepbx.org and post the link here.
Also, describe your network topology.


(Phuketmymac) #3

Awesome!

Thanks! It did it.


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.