Digium Phone Module for Asterisk Fatal Error

I tried posting this in another category but after 4 days got no response.

I used PBXIAF to do an install on a fresh machine with a brand new Digium 4 port analog telephony card. I did the “purple” install and installed FreePBX I’ve also tried the “Green” install but that hasn’t made any difference.

After the install I did a yum install of php-digium_register-3.0.4-1_centos6.i686 and restarted httpd.

Then I went into FreePBX under Digium Addons and installed the Digium Phone Module for Asterisk.

I went to the digium website and got a license for it. Back in FreePBX I clicked “Add-License” and filled in my license info. When I submit it though I get the following fatal error:


Failed to open file for license. Do you have the right permissions?

Trace Back

/var/www/html/admin/modules/digiumaddoninstaller/functions.inc.php:800 die_freepbx()
  [0]: Failed to open file for license. Do you have the right permissions?

/var/www/html/admin/modules/digiumaddoninstaller/functions.inc.php:561 digiumaddons_register->register()
  [2]: dpma

/var/www/html/admin/modules/digiumaddoninstaller/functions.inc.php:519 digium_addons->register_register()
  [2]: dpma

/var/www/html/admin/modules/digiumaddoninstaller/page.digiumaddons.php:112 digium_addons->register()
  [0]: dpma

/var/www/html/admin/config.php:414 include()
  [0]: /var/www/html/admin/modules/digiumaddoninstaller/page.digiumaddons.php

Was that RPM built for PBXinaFlash?

You might want to skip trying to use it with PBXinaFlash if it wasn’t and just register DPMA manually. That’s all the Digium Addons for FreePBX addon module helps you do anyway; it doesn’t have any bearing on the functionality of the Digium Phones Addon for FreePBX or DPMA (res_digium_phone.so).

Instructions for registering a key for DPMA are available at: