Digium D80 - EPM - No Unassigned Extensions

I have a D80 in testing that I got to successfully connect to EPM, but I was testing the phone and factory reset. Now it will not show an unassigned extension to connect to.

I have deleted the phone out of EPM.

I deleted the full extension and recreated it.

Nothing will bring back the ability to link this phone too an EPM extension.

Tap the search field, enter the extension with the keypad…ok…that’s it! EPM does not support the D80 at the current stage.

Instead of EPM try the advanced DPMA configuration…

Please try to use the latest edge release of EPM which has improved DPMA functionality.

Ref: Enhancing DPMA functionality within Endpoint Manager

Best Regards

All well and good on that front.

But after the factory reset when i boot the phone up i choose to connect manually. And from there when i enter my ip and port and global admin password found from DMPA in EPM.

This is where it asks to assign an extension and after waiting on Starting Phone.

There are no Unassigned Extensions.

Is there a flag in the DB i can check to see what is going on why i cannot find an extension.

I dont know nothing about EPM. I use the Digium phone config module and Asterisk DPMA. I experienced the same thing…once I connected a phone the first time, it never showed up again in the unassigned extensions anymore…even after a reset!
After a reset of the phone, you have to enter the extension number manually…

Ok so i guess I’m still looking for where the “unassigned extensions” is stored because when you factory reset that how am i to tell the pbx system that the extension is waiting to reestablish.

You dont have to tell the pbx…the phone asks you after the reset, which extension number it should use to connect/login to the pbx. If you dont reset the phone, it knows its extension number anyway…

Then why does my phone not find any Unassigned Extensions? Before i’d select the extension 2231 and boom off to the races.

Now it searches finds none. I type in 2231 and i get the option to Configure as extension 2231? I click Configure

Starting phone

Unable to list extensions : Error -104

Maybe because the D80 isnt supported (EPM) yet. Try the Digium phone config module instead.

Hi, @juesor Latest EPM has support for D80 phones.

Are you using the latest EPM release?

If you are using the latest EPM then please create extension mapping with your D80 phone extension. Ref to EPM DPMA Wiki


1 Like

@kgupta1 Im having the exact same issue with EPM and D80. Latest EPM and FreePBX Commercial EPM.

I installed the latest EPM last week and disabled Digium Phone Config like it instructed. I setup the extension in Extensions and in the Other tab I picked Digium, D80 and my Digium template and put in MAC. Apply Config… Factory Reset D80, it reboots, it finds the server and sits at Unassigned Extensions (the extension I am setting up is not listed)… I changed Unassigned extensions at the top of the screen to All Extensions and see all my extensions. I click the extension I want, it asks if I want to use this extension and I say yes. The phone reboots twice then just comes back to the same Unassigned Extensions screen. It will not provision…

I tried deleting the extension completely out of Extensions module…I then setup a new extension (CHAN_PJSIP) and I did NOT setup the phone in the Other tab… I then went to Extension Mapping in EPM, added a new extension, I selected the extension and account, Selected Digium as the Brand, put in the MAC, selected my Digium Template and model as D80… Apply Config, reset phone and it does the same thing… Wont provision…

It appears the D80 still isnt working properly with the latest EPM that says it supports the D80 now. Currently, I have D65 setup that work and provision perfectly with EPM… Its only this D80…

Any suggestions??

Update for anyone using or trying to use D80’s with the latest EPM that supports D80 (and all D Series phones)… Or at least its supposed to.

I opened a support ticket and Support SSH into my Server. After some time they informed me that somehow Digium Phones moduling is conflicting with EPM somehow. They didnt specify how specifically but requested to Uninstall and Reinstall the module which they did. That didnt resolve the issue…

They requested live testing which we scheduled for today to determine what is causing the issue with the D80 not provisioning through EPM. This is not a D-Series issue with EPM because my D65 provisions and works just fine. Its isolated to the D80 only. Ill update here after we do live testing today.

Another thing to note…I noticed my Digium template was gone with the latest EPM update… When I went to add it back, Digium was no longer in the list of Brands to select. Support informed me that S and D series phones have been merged under the Sangoma brand in EPM… So anyone looking for Digium template, you now select Sangoma as the brand then you will notice S Series and D Series templates within Sangoma Brand…

Step 1 when using DPMA in Endpoint Manager is to disable the Digium Phones module:

Both modules manage DPMA and neither is aware of the other. There has been no EPM testing with the Digium Phones module installed.

Yep, Im fully aware and I followed those instructions to a T. I disabled Digium Phones Module and it has been disabled since the latest EPM update before ever attempting to provision this D80… Thats not the issue here… Its disabled…

1 Like

I just went back into Module Admin to see if its still disabled after Support SSH into my Server the other day and uninstalled and reinstalled it… And Digium Phones module doesnt even exist in my modules list anymore… So I dont know what they did… Only thing in their is Digium Addons… We will see what todays live testing with support brings…

Ok, so spent some time live with support testing this D80 today. They couldnt get it working… took Asterisk logs, pcaps, and DPMA logs and PTSR file to report to the developers.

After all the testing Ive done and support, the last thing I could come up with was maybe the current firmware on the phone needs updated to a certain version to work with EPM… My phone had 1_8_16_1 on it. Since it wouldnt provision, it never did the firmware check and upgrade via Firmware Management within EPM… I had 1.29 loaded in Firmware Slot 1 but it never updated…Trying through the WEB GUI reported “The WebGUI has been disabled” message… I even tried Factory Resetting the phone and plugging it into a POE switch not connected to my phone LAN so I couldnt see my PBX but I still kept getting the “WebGUI disabled message.”

After doing some digging online I found some write ups that covered this very issue of updating firmware when you cant access the WEB GUI and PBX wont update… You can bypass the WEB GUI disabled message for firmware updates by going to http://yourphoneipaddress/firmware…And using the login credentials Username: admin and Password: 789 … I then downloaded and updated the latest 1_12_10 from here:


After the firmware update completed, the phone rebooted and upon boot up it instantly provisioned to the assigned Extension I configured with MAC in EPM>Extension Mapping.

Phone now makes and receives calls no problem, template assigned keys are working, Visual voicemail is working… So auto provisioning is working now with the latest EPM and D80 but you MUST be on the latest firmware for it to work. I dont know if it also works with any firmware versions between 1_8_16_1 and 1_12_10 but I can confirm 1_12_10 works…

Only issue is there still is a yellow Triangle in the top right corner… Status is not working. We will see what support says about that…I just updated them on my progress as they had just disconnected from SSH from getting all the logs before I did this fw update.

I finally found your response.

the admin 789 is not working for my d80

I’m still on 1_12_8 and would like to upgrade firmware

The D80 has so much potential

Manually update the D80 to latest firmware and all is well…well presence isn’t working yet and support knows that but everything else works

Since i got the D80 to talk to EPM the password is now 222222


Current Firmware Version: 1_12_8

Firmware is already configured for this phone, and cannot be managed via this interface.

NVM now that its in EPM

I have to control firmware from there. I noticed EPM was setup for 1.19 which was D80 1_11_3

So i loaded 1.29 which for the D80 is 1_12_10

I’ll see if that pushes the latest firmware or not.