Digital Ocean, Debian 12 64 and FreePBX 17 script

Hi,
I created a new Digital Ocean droplet with Debian 12 64, ran apt-get update && apt-get upgrade and then the freepbx 17 script.
All worked great, I can register the PBX, create certificates, change ports etc etc. However 2 things that dont work, and it may be Digital Ocean thats the issue.

System Admin - Network Settings fails to load

I can tweak that by changing the permissions of the /etc/network/interfaces file adding “other” to have read and write. Is there a better way to do this?

The only other issue I can see so far is I cannot change the eth0 or eth1 zone to any other type, specifically Internet. I have the Digital Ocean firewall configured, but I would prefer to use both FreePBX and DigitalOcean. Would there be any guidance on what to look at to change the eth0 zone to internet?

I have tried 3 installs so far and all have the zone issue.
I have tried changing to the Edge Modules with no difference.

Once i get the firewall sorted I can move on to more testing.

Thanks
Dave

Hi,

Same firewall issue here.

To have a working firewall a switch to network config via files in /etc/network/interfaces.d seems mandatory.

Other configs like netplan or systemd-networkd are not supported to secure the server.
Quite a limitation …

Have a look here in the code : firewall/Network.class.php at release/17.0 · FreePBX/firewall · GitHub

Thanks, looks like its the fix, I haven’t had a chance to test as I have had to jump onto a different project but will update the ticket when I do,
Best wishes
Dave