FreePBX | Register | Issues | Wiki | Portal | Support

Difficulty provisioning Sangoma Phones

freepbx
configuration
Tags: #<Tag:0x00007fcd22fac570> #<Tag:0x00007fcd22fac340>

(United Kingdom) #1

Hi all,
We have FreePBX installed and have so far got our SIP Trunk connected and working and a handful of soft phones registered. Our next step was hardware phones so we purchased a Sangoma S500 for testing purposes. The PBX and phone are on the same VLAN, EPM can succesfully detect the device by scanning the network, we select the sangoma default template. When the phone reboots we see it connects out via port 6000, 443 and 80 (to Sangoma I assume) and then it attempts to download an XML file from the PBX at which point the httpd logfile shows a 404 error which is file not found. I have tried http and tftp provisioning and there is no authentication set for the http provisioning. I can see the xml is inthe tftproot folder, any ideas??


(Steve) #2

Does it work if you manually add an extension mapping with the phones MAC address?

When the Sangoma phone first boots it reaches out to rs.sangoma.com to check for a redirect address. You don’t technical need this but might be worth trying to set your PBX server address on the phone in the Sangoma Portal.


(Tony Lewis) #3

Have you told the phone how to reach the PBX the first time with something like option 66 or our redirect server or PNP.


(United Kingdom) #4

Hi Tony,
I have tried both so far, at the moment I am using the redirect in the SangomaPortal. Neither got me much further I’m afraid, the phone seems to know the PBX address as i see that attempted download in the httpd log its the 404 thats confusing me. Do you know in what directory the config xml file should be? It seems to go to pbx_ip\00500cfg.xml (or similar) and then pbx_ip\0050phonemaccfg.xml both of which get a 404.I can see these config files in tftproot. Could it be an apache issue or permissions issue? Its a recent build that hasnt been tweaked or altered. If theresany specific logs or settings that will help Im happy to upload them.

Thanks for your help.


(United Kingdom) #5

Hi Steve, no the behaviour is the same, Ive set the redirect address and I’ve tried creating the phone manually.


(Itzik) #6

In the portal, if you want to provision locally, then you need to enter your local PBX IP and make sure you enter the provisioning port as well. (I use http works awesome) You can find the correct port under system admin.
Then, reboot the phone.


(Tony Lewis) #7

I would suggest connecting with support. Sangoma phones come with free support. Something seems off or your missing a step. Did you follow out wiki on how to connect phones.


(United Kingdom) #8

Well I feel a fool, I looked at the provisioning portal and I hadn’t included the port after the pbx ip in the provisioning url. The phone has just been through a lengthy reboot, updated its F/W and has successfully registered. I am so grateful to you and to everyone’s suggestions, I have read the deployment guide and wiki several times and can’t believe I missed this. Thanks all.


(United Kingdom) #9

Hi Tony, I’ve replied to a post one up, TLDR, I missed the port on the provisioning url, it works now and I’m sorry I wasted people’s time. I had read the wiki but obviously not in enough detail. Thanks for your help.


(system) #10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.