Difficulty changing repo selection on module admin screen

Whenever I [de]select a repo, I get a browser error:

The button color then proceeds to change but this is only visual; the repo selection is undone after a page refresh.

Any suggestions?

You have a local host issue. The server can’t talk to itself. I believe no other Ajax will for for you either across freepbx

I’m getting the same issue on a brand new install. No Firewall Changes made to block anything. Literally installed it as a VM, created the admin user, go to module admin, select Extended or Unsupported repo boxes and about 2 seconds later get “Error: Did not receive valid response from server”. This is on FreePBX 6.12.65-29 x86_64.

Oh, and I tried multiple browsers on multiple devices. Compatibility settings don’t fix it in IE either. But that would concur with your AJAX theory on the server. Just not sure what would block this on a default install.

Uninstall digium_phones module

That seems to have solved the problem for me.