DHCP Option 132


Does anyone have Yealink or Fanvil phones working with Option 132 through a Windows or SonicWALL DHCP Server?

First time trying this and I can’t get it to work. If anyone has it working and can share their configuration I’d appreciate it.


I know nothing about this, but suggest that you are much more likely to get help if you tell us what’s wrong.

Does the phone get a DHCP ACK from the right DHCP server? Does it have option 132? Does that option specify the correct VLAN ID? Does the phone attempt to register (or provision) using that ID?


The phone is set to look for option 132, I have enabled option 132 on the DHCP server with the string value of the VLAN ID, but it does not seem like the phone is pulling the configuration. At least it doesn’t “move” to the correct VLAN.
We are using Cisco switches and I have confirmed that the port is in trunk mode… So before going crazy looking at packet captures and stuff, there may be a specific requirement on SonicWALL or Windows with the way we need to write the string value, which is why I am looking for someone who already has this working and can perhaps shed some light here.


In SonicWall DHCP options, make sure that option type is “string”. Also, these settings are enabled by default but the phone must have

network.vlan.dhcp_enable = 1
network.vlan.dhcp_option = 132

If that still isn’t working then you will need a packet capture to view the DHCP Discover/Offer/Request cycle.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.