Deutche Telekom problem outbound calls

Hi guys I’m relative new in freepbx.
I have problem with Deutche telekom chan_pjsip trunk. Received calls are without any problem, but outbound calls are rejected with 401 Unauthorized

I’ve tried a lot of configurations which I found on the internet for Deutche telekom but same problem:(
Could anybody help me please?

401 is not a rejection.

The only thing odd in that trace is that the caller cancelled.

401 is a request for authentication, which seems to have been provided.

Hi Sorry here is other session

Then where I can find what is wrong :frowning:
PBX give me message all circuits are busy now :frowning:

Perhaps they require a real caller ID?

Maybe but how can I put there a Caller ID?

Did you provide YOUR caller-ID in the trunk settings, like +49…?

Don’t you use the web-gui?

I’m using web gui, caller ID in the trunk is set but there is just general number without last two numbers because we have numbers from 00 to 99,



Trunks Module - User Guide - PBX GUI - Documentation (note the NXX… sequence is an example for North America; the important point is the angle brackets.


depending on your exact needs (there may be others).

Note this user guide is for an old version.

What about the outgoing and incoming settings of the trunk? Mine look like this…an Austrian provider.

I’m using pjsip protocol not chan_sip and there is different settings


sorry…my fault…

You should be able to set the CID on the outbound route and/or on the extension.

Maybe this helps…it is older though…

I’ve read the thread and compared almost all settings with mine but still could not find the problem. Incoming calls like a charm but outgoing calls I could not make.

Did you create an outbound route?

It wouldn’t have sent the INVITE if there were no route or no trunk.

Most likely you will find the answer in the log file: /var/log/asterisk/full

Yes I’ve created