Delay in calling mobile phones

Hi Guys and Gals, I have set up my first ever PBX and thanks to these forums and a lot of searching it has all gone quite well. I have one small issue though, there seems to be a delay from anywhere between 4-12 seconds making a call via the voipfone trunk. It’s fine calling landlines and other people on the same sipfone network but just a bit slow to mobiles. From reading the forums this is just the way it is and more of a cellular network issue however I have a box of tricks that basically registers as a sip extension and the longest time I can set the “wait PBX Ack Timer” is 10 seconds. What seems to happen is if the mobile is in a bad area and the total delay from the device calling the mobile through the voipfone / cellular network is more than10 seconds it thinks the call has failed and gives up however the pbx still carries on and you get the mobile ringing with no one on the other end. Is there anyway of faking the pbx to pick up the call and then say forward it on, or is there any timers that can be changed of the freepbx side? Any help appreciated.

You would have to more fully describe your “box of tricks”, no mind readers here . .

Sorry, It’s a Two Way Radio Repeater with built in sip, the settings are very limited screen shot here https:// www (remove spaces) . The radio hansets then each have an ID that register via this radio. The secret has to be common for all of the hansets.

I would suggest you try adding r and/or perhaps a to the dial options for that extension

(Do the hansets look like this ? )

Thanks for the reply, quick question, can these options be set via the freepbx gui or is a ssh in job? Sorry don’t understand your second link.

Yes they can be set from the extension page

Compare that second with

It was a poor joke.

Hi Dicko, I assume it’s under Asterisk Dial Options. default is “tr” , using override I have tried “tra” and “ra” and just “a” but neither seem to make any difference. I was hoping that the radio hand held would just get ring regardless if the call to the mobile had gone through. As soon as the mobile starts to ring the radio rings and as long as this happens within 10 seconds then not a problem. I wonder if I can do something like ring an extension (because thats quick) that forwards it onto the mobile?

You need to force an answer to the extension before the call is answered because of your incompetent hardware. Perhaps a custom
(pseudo code)
Exten => if its the bogus device then answer () and continue

something in /etc/asterisk/extensions_custom.conf like (from bash) :-
echo ’

; for the stupid thing
exten => _X.,1,DumpChan() ; for your debugging convenience :slight_smile:
exten => _X.,n,GotoIf($["${CALLERID(num)}" = “123456789”]?forceanswer:carryon)
exten => _X.,n(forceanswer),Answer()
exten => _X.,n(carryon),Noop(Carrying On)
; end stupid thing

’ >> /etc/asterisk/extensions_custom.conf
rasterisk -x reload

Wow thanks for the reply, looks at little beyond me at the moment but I will give it a go

In our experience depending on the carrier it at times takes 2 rings before the first ring gets to the cell phone with certain carriers ( AKA sprint ) while others are more immediate.