FreePBX | Register | Issues | Wiki | Portal | Support

Default language, system recordings and wrong announcement language


#1

Hi,

I’ve Freepbx13 and Asterisk 13. Uptodate modules.

My default langue is French in Sound Language Module.

I put some system recordings that I use for annoncements. I put the System recording in French language (to match with my default language setting).

But when I’ve in use the system recording in a ring group or an IVR, Asterisk read the file in english format :

Playing 'custom/repondeur.slin' (language 'en')

Why ???


#2

You need to set the language on the channel, it is documented in the wiki

https://wiki.freepbx.org/plugins/servlet/mobile?contentId=61800936#content/view/61800936


#3

There is no explaination how to change the language on the channel in

https://wiki.freepbx.org/plugins/servlet/mobile?contentId=61800936#content/view/61800936

I’ve already set “Global Language” on French


#4

Does

ls -l /Var/lib/asterisk/sounds/fr/custom/repondeur.slin

Show it exists and is owned by asterisk ?


#5

/Var/lib/asterisk/sounds/fr/custom/repondeur.wav exists with asterisk rw-rw-r–

But the sound is not played. If I put the file in

/Var/lib/asterisk/sounds/en/custom/repondeur.wav

it works


#6

Then you have somehow you mis-configured the language settings, pragmatically if you only use fr then copy them all into …/en and the will work, more particularly you can use DumpChan() on the channel to see what it is.


(Marbled) #7

Bonjour!
(Hi!)

Which language is/are your Inbound route(s) set to?

This is under Connectivity > Inbound Routes > YOUR_INBOUND_ROUTE > Other > Language.

I have inbound routes with different default languages and everything works A-OK, it always uses what I set there…

Bonne chance et bonne journée!
(Good luck and have a nice day!)

Nicolas


#8

Thank you Marbled. The default system language for ma PBX is French. And in the Inbound route, in language setting, Default is selected. So it should be French sounds to be played.

I will look at this anyway.


#9

Hi, in INBOUND ROUTES module, there is no more the LANGUAGE option in OTHER section.


(Marbled) #10

Bonjour!
(Hi!)

Please don’t tell my FreePBX 13.0.192.14 system that I just made sure every module was up to date… :wink:

It’s most definitely there (3rd field) with the web UI in either English or French…

Maybe it’s some sort of rendering problem, you might want to clear the browser cache or try another browser…

Bonne chance et bonne journée!
(Good luck and have a nice day!)

Nicolas