Default codecs


(Marc) #1

Hi

I have no audio except if I set an allowed codecs string for each device (g722&alaw&g729).
The default audio codecs checked on General SIP settings is not applied.

Is this the expected behavior ?

I remember having found the advice long time ago when I started creating PJSIP extensions in a mixed envt mainly CHANSIP, a couple of PJSIP.

FreePBX 15.0.16.53
D&U mode set. Checking if it does work for me.

Thx
Marc


(Matt Brooks) #2

As far as I know, codecs allowed in the general settings will also be allowed unless removed with the ‘disallow’ directive. If it’s not working and the correct codecs are specified in the general settings, then I have no idea what’s wrong here.