Declined (603) error

I have 2.11 and am getting a declined(603) on my softphone and Cisco 7940g when dialing out.

dialing between extensions works fine. Incoming works fine… so I know it is not a phone registration/ codec/ NAT/ password / etc/ etc issue (all the stuff I have seen to check so far)

a snippet from debug is

[2013-05-16 17:28:38] DEBUG[2744]: pbx.c:4298 pbx_substitute_variables_helper_full: Function result is ‘outbound-1-2’
[2013-05-16 17:28:38] DEBUG[2744]: pbx.c:4470 pbx_extension_helper: Launching ‘GotoIf’
– Executing [[email protected]:3] GotoIf(“SIP/101-00000028”, “1?outbound-1-2,9056324018,2:outbound-allroutes,9056324018,2”) in new stack
[2013-05-16 17:28:38] DEBUG[2723]: manager.c:4300 match_filter: Examining event:
Event: Newexten
Privilege: dialplan,all
Channel: SIP/101-00000028
Context: from-internal
Extension: 9056324018
Priority: 3
Application: GotoIf
AppData: 1?outbound-1-2,9056324018,2:outbound-allroutes,9056324018,2
Uniqueid: 1368739718.52

-- Goto (outbound-1-2,9056324018,2)

[2013-05-16 17:28:38] WARNING[2744]: pbx.c:5363 __ast_pbx_run: Channel ‘SIP/101-00000028’ sent into invalid extension ‘9056324018’ in context ‘outbound-1-2’, but no invalid handler
[2013-05-16 17:28:38] WARNING[2744]: pbx.c:5363 __ast_pbx_run: Channel ‘SIP/101-00000028’ sent into invalid extension ‘9056324018’ in context ‘outbound-1-2’, but no invalid handler
[2013-05-16 17:28:38] DEBUG[2744]: channel.c:2731 ast_softhangup_nolock: Soft-Hanging up channel ‘SIP/101-00000028’

I have an outbound route with ‘stanandard’ dial plans (7/10 digit dialling, emerg, info, etc) … however, what is strange is if I delete all outbound routes, I get the same result when dialing out, that is, the 603. So, after much scratching of the head, I am thinking that the system for whatever reason is not ‘looking’ at the outbound route/ dial plan at all… does that sound like a possibility or am I off base? Any help would be appreciated, I am at my wits end.

Soooo… kept at this and have found the solution…

this system was installed for testing about 2 months ago and orignally the dial out was working… recently we upgraded to the latest modules. That is about the time the outbound started to do the 603 error.

the solution, in hindsight is simple (despite the 4 days-ish of trying to troubleshoot, delete the extension, recreate the extension, voila! You can now dial out… VERY frustrating, but, it is fixed.

Actually you only had to resubmit the extension would be my guess.

Very odd.

Actually no, i had tried various settings on the extensions and had resubmitted them dozens of times and no joy. The delete and re-create fixed it 1st time…

Ok, I was thinking the Asterisk Berkley DB had gotten hosed and an old bug crept back.

Glad it wasn’t that…Sorry you had to go through this.