FreePBX | Register | Issues | Wiki | Portal | Support

DC201 / DB20 Call waiting tone


(Jimmy Raineri) #1

I’m looking for a way to alter the call waiting tone that plays in the earpiece of a DB20 handset when a second extension is ringing while in an active call.

If there a way to eliminate this tone? Is there a way to at least change the frequency to once every 30 seconds or 60 seconds instead of (what seems like) every 5 seconds?

I realize the user can press reject to reject the call and stop the tone. But that isn’t what I want to do - I want the second call to continue to ring so that when I hang up the first call, the second call will be answerable on that same handset. But the constant call waiting beeping makes it almost impossible to continue on with the first call.

If altering the tone is not possible - is there a way to present the second call to the handset once the first call is ended? (with “call waiting feature” disabled).

(Note: Configuration is 2 extensions (sip accounts) defined, 2 handsets, both are configured with both extensions)


(Tom Ray) #2

The tone will play with every ring because that is what the tone is, ring indication. You should be able to go into the Endpoint Manager and under the Options tab for the profile template set the “Call Waiting Signal” to disabled. That should tell the device not to play the tone to the user.


(Jimmy Raineri) #3

I tried that but it didn’t work.

It appears that the DC20 does not have that P8850 code to set.

I was unable to find the equivalent directly in the basestation web admin GUI itself.