Date is off by 1 day

We just setup a freepbx server and all of our phones + voicemail details are 1 day behind. I set the correct time zone (Eastern Standard) and we have the right time but Im not sure how to change the date.

You didn’t mention any details about your system.

If you log into the command line and enter the date command what do you see?

Is the time zone set correctly for your phones? Are the phones configured to use an NTP server?

Sorry Im a newbie. We are using aastra 9133i phone. When I login to the command line and type date I get Wed Jan 25 10:08:44 EST 2012. So I guess I need to simply change the date in there?

No worries about being new to this.

The server should be setup to use Network Time Protocol (NTP) to get the correct time.

What FreePBX version are you using? Is this a distro install or built by hand? The distro install would have configured NTP.

I am not that familiar with Aastra phones as I do mostly Polycom. That being said I would think that the Aastra phones need to be configured to use an NTP server also.

Once you reminded me about command line I got it. I changed it using this format:
date 062915302006


There is a timezone setting in “/etc/php.ini” file. Try editing it and set “date.timezone” parameter same as system timezone.

if there are any other time zone issues then do the following

  • $ ln -s /usr/share/zoneinfo/America/Chicago /etc/localtime
  • $ echo “export TZ=America/Chicago” >> /etc/profile

on some redhat based systems set the settings as below.

  • $ cat /etc/sysconfig/clock