DAHDI module

Can anybody tell me where the DAHDI module is located to configure a Sangoma A200, under connectivity i have only got DAHDI Channel DIDs and no configuration module.

Am i looking in the right place ?

If you using FreePBX distro in latest version you should have in Connectivity -> DAHDI Config.
I noticed that sometimes, during installation if you do not have access to the Internet, is part of the modules in the menu is not available.

You first might need to enable the dahdi module inside the module admin, and may have to click the extended tab in order for it to be found.

Not sure if the module is finding the Sangoma cards properly though - give it a try

in the dahdi module you also need to check the box under sangoma options.

Once the module is enabled, you should see your FXO and FXS ports listed under dahdi config and analog hardware. They might not show up though - I’m having an issue with the channels not being recognized, not sure if it’s my issue.

The module wasnt installed, now installed but not seeing the card

In Modprobe setting its high lighted as wctdm24xxp is this right ?

In Sangoma settings, Run Wanpipe In DAHDI/DIGIUM Mode: yes and then a choice of T1 or E1.

Mine is the same - fresh install from the distro and doesnt configure the card. Wasnt sure if it was something I did, or didnt do.

Might have to manually install it

Looking like the same here, distro was the latest one 2 days old.

Checked the Sangoma box, but it wont save the details

Has anyone found the solution to this? I have tried the latest distro in both 32 and 64 bit. I even purchased a new card because I though the original card was bad, since Dahdi didn’t find it.

To recap, brand new install from distro. Did all of the updates and installs. And the Dahdi module does not “find” my sangoma a200 card.

Uninstall the module and run setup-sangoma and see if that works.

ok, I was able to uninstall the dahdi config module, then re-install it.

For the second part of your guidance “run setup-sangoma” I am not sure if I understand. There is a “sangoma settings” menu on the DAHDI config page. When I click on the “Sangoma settings” menu the only option is “Run wanpipe in DAHDI/digium mode” The default is “no”. I have tried it with “yes” with both e1 and t1 selected. Neither fixes the issue. Is this what you are referring to? If not could you guide me to what you are referring to?

Also note that when I select the “yes” and save the config, when I go back it is always “no”


setup-sangoma is a Linux application that comes with Wanpipe. It has nothing to do with FreePBX. I am trying to take FreePBX out of the equation.

If you setup successfully with setup-sangoma you can configure a DAHDI trunk and be all set.

I also couldnt get it to work - same deal wouldnt see the card. Well it would see it, and install the dirver and wanpipe, but you could never see the channels.

I had to install manually - follow the instructions @ sangoma - just leave out the part of downloading asterisk


ok, I tried the link was able to download the dahdi, and libpri. I skipped the asterisk. Te problem is that when running setup the following failed the check:
ncurses library

I tried to continue anyway but then it cant find zaptel/dahdi.

This cant be normal, would it be better to go to a previous release? Do the previous releases have this many issues?

At one point it did work - a few months ago I put one in and it wokred ok all through the distro as I recall.

I did the librpi one, and you’ll have to do install all of the dependencies

Couldnt get the card to be found, followed manual instructions and can see the card but it does not show up in FreePBX

Wanpipe Hardware Probe Info

1 . AFT-A200-SH : SLOT=4 : BUS=2 : IRQ=11 : CPU=A : PORT=PRI : HWEC=32 : V=13

Sangoma Card Count: A200=1

localhostCLI> dahdi show channels
Chan Extension Context Language MOH Interpret Blocked State Description
pseudo default default In Service
CLI> module load chan_dahdi.so
Unable to load module chan_dahdi.so
Command ‘module load chan_dahdi.so’ failed.
[2014-05-31 21:57:40] WARNING[5314]: loader.c:908 load_resource: Module ‘chan_dahdi.so’ already exists.


Can someone open a bug report so this can get resolved.

I would but where do you find all the information needed to open a Bug report, found half of it but struggling to find the rest.