DAHDi Issues after 13 to 14 Upgrade

Just upgraded a system from FreePBX 13 to 14. Since updgraded, the system no longer recognizes the Digium A4B analog card in the analog tab of DAHDI Configuration.

Here’s the output from dahdi_hardware:

pci:0000:01:00.0 wcaxx- d161:8010 Digium A4B

Under Module settings, I’ve only selected wcaxx. Under Modprobe settings, wcaxx is selected for Module Name.

Also tried running dahdi_genconf, and all that was displayed was

Empty configuration – no spans

What else may have changed during the upgrade that would break this functionality?

Quick update:

Just ran the command ‘modprobe wcaxx’ and now the FXO and FXS channels are displaying in FreePBX. The channels are not functioning though.


please check from asterisk CLI, if there is no spans, you may add:
[trunkgroups] in chan_daidi.conf and reload again,

I think I’m narrowing this down a bit. It looks the the modprobe setting from the gui aren’t writing to /etc/modprobe.d/dahdi.conf. No changes made in the gui show up there. Tried reinstalling the dahdiconfig module, but still no joy.

Is there a bug somewhere, or am I missing something here?

What user owns that file?

Not sure what user, but I have ran fwconsole chown.

Finally got things working, here’s what I had to do:

  1. Comment/delete any lines in /etc/modprobe.d/dahdi.conf
  2. Run command ‘modprobe wcaxx’
  3. Add context ‘from-analog’ to FXO ports

This doesn’t survive a reboot though. After a reboot, here’s the output from dahdi_hardware:

pci:0000:01:00.0 wcaxx- d161:8010 Digium A4B

It also reverts /etc/modprobe.d/dahdi.conf. Under DAHDI Configuration, all the analog ports are blank.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.