Dahdi echocanceller oslec

Asterisk 11.7.0
Dahdi 2.9.0
Centos 6.5 Linux 2.6.32-431

The System worked fine until a power blackout. The System startet without errors, also asterisk. But the ISDN-Lines didnt work.
If I restart Amportal, I recive the error: “DAHDI_ATTACH_ECHOCAN failed on channel 1: Invalid argument(22)”

I detect, that dahdi want to use oslec and not mg2, but i have not installed oslec and i want to use mg2.
How can I force dahdi to use mg2 and NOT to use oslec??



replace oslec with mg2

I have changed it manualy, But if I make a restart I have to changed it again.
This is not so fine.

How are you configured?
Meaning what method…

If you are using the dahdi “helper” module, I suggest that you disable it, it likes helping only a subset of dahdi’s abhilities and I believe it overwrites /etc/dahdi /system.conf with it’s idea of what it should be.

Given that, I find that OSLEC is far better than MG2 for software echo cancellation, it is easy to compile it when you “roll your own” dahdi, just add a recent linux-source staging/echo structure to dahdi’s drivers/staging directory before “make all”, one recipe at the top of:-