DAHDi Doesn't appear to be running

Over the weekend i upgraded to 10.13.66-22 from 6.12.65-32

I did this installing each incremental update.

DAHDi Doesn’t appear to be running. Click the ‘Restart DAHDi & Asterisk’ button below

Whoops\Exception\ErrorException Undefined index: channel File:/var/www/html/admin/modules/dahdiconfig/includes/dahdi_cards.class.php:907

Any help or advice greatly appreacated



worked with Digium for several hours and they are convinced that this is a freepbx issue as the error points to a php file.

any help greatly appreciated.


DAHDI is a separate process from both Asterisk and FreePBX.

Your first question was about DAHDI not running. I assume since you were on the phone with Digium, they actually checked to make sure that DAHDI was installed correctly and that the ‘dahdi’ program was running.

Did they walk you through the on-line diagnostics?

The error message is about the channel variable, or the lack thereof. Did you review the config files to make sure your channels are set up correctly in the config files?

Without more information, help isn’t probably forthcoming. So far, all we’ve got is that there’s an error in a program that thousands of other people are using without a problem. We’re going to need more information from you to be able to help you.


thank you for responding.

yes digium did a remote session for several hours and insured all was as they think it should be. Dahdi would not start. they believe that is is a config file generated by FreePbx that is causing errors.

As i have not configured DAHDI beyond what is on the FreeBbx setup, please tell me where to look and to look for as well as what additional information you need.

All was working as expected before i upgraded.

Thank you for your assistance.


Do you still have the backup dahdi config files?

There has been a lot of discussion over the years about FreePBX being allowed to manage dahdi. Many of us (for several reasons) do not let FreePBX manage our DAHDI config. If the FreePBX config isn’t working, then you should probably join the club and set up dahdi outside of Asterisk and do not allow FreePBX to write those files.

I understand that this is harder than using a click-and-drool interface, but sometimes you have to man-up and do it the hard way. Sorry.

my chan_dahdi_groups.conf is empty

this could be at least a part of my issue?

attempting to recreate using info from a similar system.

any other advice greatly appreacated

recreated the chan_dahdi_groups.conf then ran amportal chown restarted dahdi usung the button on the dahdi page.

and the same error message.

Please any help appreacated

Go into the DAHDI module in FreePBX and save your configuration settings and restart.


tried saving settings but it did not resolve, still getting an error

Whoops\Exception\ErrorException Undefined index: channel File:/var/www/html/admin/modules/dahdiconfig/includes/dahdi_cards.class.php:907

please any other ideas?


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.