Dahdi-channel.conf not updated bu GUI

Editing the context in zap (via DAHDI compatibility) in extensions does not update /etc/asterisk/dahdi-channels.conf
I have to go manualy and edit this file in order for the context callerid etc…to take effect.
I have in chan_dahdi.conf the line #include dahdi-channels.conf

There is no zapata.conf in /etc/asterisk

How can I have the web interface on FreePBX to update context, etc… without having to manualy edit dahdi-channels.conf every time.

The dahdi channels does work, I can make and receive calls, so installatoin is ok.

We saw your post from yesterday. No need to repost it.

I don’t have a setup with DADHI currently to check it, when somebody who does can they will respond. Many of the developers this week are out doing a training presentation so it is possible that it will take a while longer to get an answer.

In the meanwhile I just keep editing the file manualy.


The file beeing updated by GUI extensions is /etc/asterisk/chan_dahdi_additional.conf
In chan_dahdi.conf I had the line #include chan_dahdi_additional.conf

Since the GUI updates chan_dahdi_additional.conf and DAHDI only see the context if it’s in dahdi-channels.conf I had to bring the context parameter from chan_dahdi_additinal.conf into dahdi-channels.conf

Just add in dahdi-channels.conf the line context=[xxx] xxx=extension number


Something does not sound right.

The file chan_dahdi.conf
should have the context [channels] in it and the lines following it should look something like:


; include dahdi extensions defined in FreePBX
#include chan_dahdi_additional.conf

My installation of AsteriskNOW 1.5.0 stable release does not have a:


The only .conf files are:


I have the same issue as caller id is not showing up on calls made from the dahdi channels although calls made to the extensions are routed correctly.

I have added in the /etc/asterisk/chan_dahdi.conf:


#include chan_dahdi_additional.conf

I will test tomorrow whether this solved the callerid issue or not.